aboutsummaryrefslogtreecommitdiff
path: root/utils/uvcdynctrl
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-06-19 18:39:18 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-19 20:49:40 +0200
commit3d50afdf3c32ced1e34bab98567975aba49c7360 (patch)
tree13eb476efe78af2a7c13dba3ff6f6fb300c86a1d /utils/uvcdynctrl
parentbc0085a70f306793318da08233cde79d883b9a7e (diff)
uvcdynctrl: get rid of udev
The udev rule installed was ineffective as udev cannot run in coexistence with procd. If needed, it should be reimplemented as rule under /etc/hotplug.d/ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils/uvcdynctrl')
-rw-r--r--utils/uvcdynctrl/Makefile19
1 files changed, 2 insertions, 17 deletions
diff --git a/utils/uvcdynctrl/Makefile b/utils/uvcdynctrl/Makefile
index 7ab033c55..a6878736e 100644
--- a/utils/uvcdynctrl/Makefile
+++ b/utils/uvcdynctrl/Makefile
@@ -9,6 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uvcdynctrl
PKG_VERSION:=0.2.4
+PKG_REV:=2
PKG_SOURCE:=libwebcam-src-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libwebcam
@@ -23,7 +24,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/uvcdynctrl
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libwebcam +PACKAGE_UVCDYNCTRL_UDEV_RULE:udev
+ DEPENDS:=+libwebcam
TITLE:=Manage dynamic controls in uvcvideo
URL:=http://sourceforge.net/projects/libwebcam/
MENU:=1
@@ -35,16 +36,6 @@ define Package/uvcdynctrl/description
- uvcdynctrl: Manage dynamic controls in uvcvideo (GPL)
endef
-define Package/uvcdynctrl/config
-config PACKAGE_UVCDYNCTRL_UDEV_RULE
- bool "uvcdynctrl udev rule, selects udev"
- depends on PACKAGE_uvcdynctrl
- default no
- help
- Installs an udev rule to load uvcdynctrl with dynamic controls
- from xml files in /usr/share/uvcdynctrl when a webcam is attached.
-endef
-
define Package/libwebcam
SECTION:=libs
CATEGORY:=Libraries
@@ -64,12 +55,6 @@ define Package/uvcdynctrl/install
$(INSTALL_DIR) $(1)/usr/{bin,share}
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uvcdynctrl* $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/share/uvcdynctrl/ $(1)/usr/share/
-
-ifeq ($(CONFIG_PACKAGE_UVCDYNCTRL_UDEV_RULE),y)
- $(INSTALL_DIR) $(1)/lib/udev/rules.d
- $(CP) $(PKG_INSTALL_DIR)/lib/udev/rules.d/*.rules $(1)/lib/udev/rules.d/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/udev/uvcdynctrl $(1)/lib/udev/
-endif
endef
define Package/libwebcam/install