aboutsummaryrefslogtreecommitdiff
path: root/utils/uvcdynctrl/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-20 15:42:44 -0700
committerRosen Penev <rosenp@gmail.com>2019-06-20 16:46:06 -0700
commit6f18a460fe6b7ded7d941001547bcacf596202f5 (patch)
treee7f69906504b2ced3dd784efac500771884fae20 /utils/uvcdynctrl/patches
parent274b111782c1d7650ae244a16e141e39d339af32 (diff)
uvcdynctrl: Fix compilation with uClibc-ng
Got rid of libiconv-full dependency. Relying on nls.mk Fixed up the license information. Added CMAKE_INSTALL to get rid of the InstallDev section. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/uvcdynctrl/patches')
-rw-r--r--utils/uvcdynctrl/patches/010-iconv.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/uvcdynctrl/patches/010-iconv.patch b/utils/uvcdynctrl/patches/010-iconv.patch
new file mode 100644
index 000000000..5f0e535e1
--- /dev/null
+++ b/utils/uvcdynctrl/patches/010-iconv.patch
@@ -0,0 +1,11 @@
+--- a/uvcdynctrl/CMakeLists.txt
++++ b/uvcdynctrl/CMakeLists.txt
+@@ -77,7 +77,7 @@ include_directories (../common/include)
+ include_directories (${CMAKE_CURRENT_BINARY_DIR})
+ link_directories (${LIBWEBCAM_BINARY_DIR}/webcam)
+
+-target_link_libraries (uvcdynctrl webcam)
++target_link_libraries (uvcdynctrl webcam iconv)
+
+ # Compiler flags
+ set_target_properties (uvcdynctrl PROPERTIES