aboutsummaryrefslogtreecommitdiff
path: root/utils/unrar
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-02 11:32:19 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-02 11:32:19 -0700
commit6ecc58abcebe4e05b0e0933975182380c27bd7f9 (patch)
tree084f877b1fd37f9661e03d281dfd3846dc95b466 /utils/unrar
parentc275bd2bf4697e765d9bc73773f52efbc0bc24d0 (diff)
unrar: Properly pass LDFLAGS
External toolchains don't automatically have STAGING_DIR in their default search path, so make sure we pass TARGET_LDFLAGS down. Since the unrar makefile does not allow overriding, we also need to preserve the original LDFLAGS which include lpthread. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'utils/unrar')
-rw-r--r--utils/unrar/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/utils/unrar/Makefile b/utils/unrar/Makefile
index 36d37b3db..b3b70f22f 100644
--- a/utils/unrar/Makefile
+++ b/utils/unrar/Makefile
@@ -58,6 +58,9 @@ define Package/libunrar/description
archives
endef
+MAKE_FLAGS += \
+ LDFLAGS="$(TARGET_LDFLAGS) -lpthread"
+
ifeq ($(BUILD_VARIANT),lib)
define Build/Compile
$(call Build/Compile/Default,lib)