aboutsummaryrefslogtreecommitdiff
path: root/utils/unrar
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-03-15 14:47:17 +0200
committerTianling Shen <cnsztl@gmail.com>2024-03-22 16:06:37 +0800
commit0cc5590999feb21eab2211c6803572a99a66b7b8 (patch)
tree0311758d057bba4a5a41111b12e1fbeac467a8eb /utils/unrar
parent7a7a87dfbd641d794297ff5b13c0fad5d2daa22c (diff)
unrar: update to 7.0.7
Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils/unrar')
-rw-r--r--utils/unrar/Makefile5
-rw-r--r--utils/unrar/patches/100-makefile_fixes.patch10
2 files changed, 8 insertions, 7 deletions
diff --git a/utils/unrar/Makefile b/utils/unrar/Makefile
index 00e59ae86..2deb6d3b8 100644
--- a/utils/unrar/Makefile
+++ b/utils/unrar/Makefile
@@ -6,12 +6,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=unrar
-PKG_VERSION:=6.2.12
+PKG_VERSION:=7.0.7
PKG_RELEASE:=1
PKG_SOURCE:=unrarsrc-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.rarlab.com/rar
-PKG_HASH:=a008b5f949bca9bb4ffa1bebbfc8b3c14b89df10a10354809b845232d5f582e5
+PKG_HASH:=da95829c7e66fe461c06eb4bea8145e58d88d76909432d0875cd1ff86669f728
+
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/unrar
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>, \
diff --git a/utils/unrar/patches/100-makefile_fixes.patch b/utils/unrar/patches/100-makefile_fixes.patch
index acd633759..610379c8d 100644
--- a/utils/unrar/patches/100-makefile_fixes.patch
+++ b/utils/unrar/patches/100-makefile_fixes.patch
@@ -5,10 +5,10 @@
# Linux using GCC
-CXX=c++
--CXXFLAGS=-O2 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
+-CXXFLAGS=-march=native -O2 -std=c++11 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
-LIBFLAGS=-fPIC
+CXX?=c++
-+CXXFLAGS?=-O2 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
++CXXFLAGS?=-march=native -O2 -std=c++11 -Wno-logical-op-parentheses -Wno-switch -Wno-dangling-else
+LIBFLAGS?=-fPIC
DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DRAR_SMP
-STRIP=strip
@@ -20,9 +20,9 @@
+LDFLAGS?=-lpthread
+DESTDIR?=/usr
- # Linux using LCC
- #CXX=lcc
-@@ -170,7 +170,7 @@ uninstall-unrar:
+ ##########################
+
+@@ -69,7 +69,7 @@ uninstall-unrar:
rm -f $(DESTDIR)/bin/unrar
install-lib: