aboutsummaryrefslogtreecommitdiff
path: root/utils/tmux
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-06-02 02:50:09 +0200
committerDaniel Engberg <daniel.engberg.lists@pyret.net>2017-06-02 02:58:40 +0200
commitdacc820fe4990d0b86b1982bd8ddaf71f745b06d (patch)
treee078d5d3ccda7c0c0d982308f1bb9e071d68f891 /utils/tmux
parent31db48a506187583bd2c370682751b6b9f7cc90b (diff)
utils/tmux: Update to 2.5
Update tmux to 2.5 Drop patch Update homepage URL Use toolchain functionality for configuring and compiling Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'utils/tmux')
-rw-r--r--utils/tmux/Makefile11
-rw-r--r--utils/tmux/patches/100-b64_ntop-conflict.patch41
2 files changed, 4 insertions, 48 deletions
diff --git a/utils/tmux/Makefile b/utils/tmux/Makefile
index 593a9c02f..c88ae0bd2 100644
--- a/utils/tmux/Makefile
+++ b/utils/tmux/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tmux
-PKG_VERSION:=2.3
+PKG_VERSION:=2.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/tmux/tmux/releases/download/$(PKG_VERSION)
-PKG_MD5SUM:=55313e132f0f42de7e020bf6323a1939ee02ab79c48634aa07475db41573852b
+PKG_HASH:=ae135ec37c1bf6b7750a84e3a35e93d91033a806943e034521c8af51b12d95df
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=ISC
@@ -21,6 +21,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -30,17 +31,13 @@ define Package/tmux
SUBMENU:=Terminal
TITLE:=Terminal multiplexer
DEPENDS:=+libncurses +libevent2 +libpthread +librt
- URL:=http://tmux.sourceforge.net/
+ URL:=http://tmux.github.io/
endef
define Package/tmux/description
tmux is a modern, BSD-licensed alternative to GNU screen.
endef
-MAKE_FLAGS += \
- PREFIX="/usr" \
- PLATFORM="linux"
-
define Package/tmux/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tmux $(1)/usr/bin/
diff --git a/utils/tmux/patches/100-b64_ntop-conflict.patch b/utils/tmux/patches/100-b64_ntop-conflict.patch
deleted file mode 100644
index 5afc9b742..000000000
--- a/utils/tmux/patches/100-b64_ntop-conflict.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/compat.h b/compat.h
-index 8666a1d..2a44a2b 100644
---- a/compat.h
-+++ b/compat.h
-@@ -223,7 +223,9 @@ int daemon(int, int);
- #ifndef HAVE_B64_NTOP
- /* b64_ntop.c */
- #undef b64_ntop /* for Cygwin */
--int b64_ntop(const char *, size_t, char *, size_t);
-+int local_b64_ntop(const char *, size_t, char *, size_t);
-+#else
-+#define local_b64_ntop b64_ntop
- #endif
-
- #ifndef HAVE_FORKPTY
-diff --git a/compat/b64_ntop.c b/compat/b64_ntop.c
-index 2b4dc2d..a1314ca 100644
---- a/compat/b64_ntop.c
-+++ b/compat/b64_ntop.c
-@@ -122,7 +122,7 @@ static const char Pad64 = '=';
- */
-
- int
--b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
-+local_b64_ntop(uint8_t const *src, size_t srclength, char *target, size_t targsize) {
- size_t datalength = 0;
- uint8_t input[3];
- uint8_t output[4];
-diff --git a/tty.c b/tty.c
-index 7be952c..06dedab 100644
---- a/tty.c
-+++ b/tty.c
-@@ -1134,7 +1134,7 @@ tty_cmd_setselection(struct tty *tty, const struct tty_ctx *ctx)
- off = 4 * ((ctx->num + 2) / 3) + 1; /* storage for base64 */
- buf = xmalloc(off);
-
-- b64_ntop(ctx->ptr, ctx->num, buf, off);
-+ local_b64_ntop(ctx->ptr, ctx->num, buf, off);
- tty_putcode_ptr2(tty, TTYC_MS, "", buf);
-
- free(buf);