aboutsummaryrefslogtreecommitdiff
path: root/utils/tio
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-11-06 22:09:26 +0100
committerDaniel Engberg <daniel.engberg.lists@pyret.net>2017-11-06 22:36:03 +0100
commitbc8c4039196192593de27bc664c5391d19da8bd6 (patch)
tree935196194906cb81def33bb864b3b7e298a41070 /utils/tio
parent288a54b17fd2fce9f15a5fdde4c509b441d7f3ef (diff)
tio: Add to tree
tio is a simple TTY terminal I/O application It's smaller than picocom, uses GNU autotools and has some nice features Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'utils/tio')
-rw-r--r--utils/tio/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/utils/tio/Makefile b/utils/tio/Makefile
new file mode 100644
index 000000000..9d67dcd18
--- /dev/null
+++ b/utils/tio/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2017 Daniel Engberg <daniel.engberg.lists@pyret.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tio
+PKG_VERSION:=1.26
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Daniel Engberg <daniel.engberg.lists@pyret.net>
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/v$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_HASH:=f9532d519fcc7d19b25fbe9fc1ee857dc10e5862a450b4b3b423f8e8538f2500
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tio
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A simple TTY terminal I/O application
+ URL:=https://tio.github.io/
+ SUBMENU:=Terminal
+endef
+
+define Package/tio/description
+ A small and simple TTY terminal I/O application
+endef
+
+define Package/tio/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tio $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,tio))