aboutsummaryrefslogtreecommitdiff
path: root/utils/telldus-core
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-03 17:01:08 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-04 13:23:03 -0700
commit8a977c8b6ec0d25b6fd07b232f6f182a817c1cfe (patch)
tree057870a7cf2444660643d9386af623b37e0fe80f /utils/telldus-core
parent1d4a09e0c5e7dd05dff5477f51eb3bddfbf74ae9 (diff)
telldus-core: Makefile cleanups
Fixed license information. Add PKG_BUILD_PARALLEL to explicitly disable parallel builds. Fixed build depends to apply only to non glibc. Added an alternative fix to ICONV_FULL which should work better. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/telldus-core')
-rw-r--r--utils/telldus-core/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/utils/telldus-core/Makefile b/utils/telldus-core/Makefile
index ea3ba6ff5..ec1beaf9c 100644
--- a/utils/telldus-core/Makefile
+++ b/utils/telldus-core/Makefile
@@ -7,14 +7,19 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=telldus-core
PKG_VERSION:=2.1.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
-PKG_LICENSE:=LGPL-2.1
-PKG_BUILD_DEPENDS:=argp-standalone
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.telldus.com/TellStick/Software/telldus-core/
PKG_HASH:=a20f6c74814afc23312d2c93ebbb37fdea9deaaee05ae7b6a6275e11e4662014
-PKG_INSTALL:=1
+
+PKG_MAINTAINER:=Peter Liedholm <PeterFromSwe884@gmail.com>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+CMAKE_INSTALL:=1
+PKG_BUILD_PARALLEL:=0
+PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -24,8 +29,7 @@ define Package/telldus-core
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Telldus TellStick USB interface
- URL:=http://www.telldus.com
- MAINTAINER:=Peter Liedholm <PeterFromSwe884@gmail.com>
+ URL:=https://telldus.com
DEPENDS:=+confuse +libftdi +libstdcpp $(ICONV_DEPENDS)
endef
@@ -34,17 +38,17 @@ define Package/telldus-core/description
MUST be built with full language support, (don't know how to DEPEND that)
endef
+define Package/telldus-core/conffiles
+/etc/tellstick.conf
+endef
+
CMAKE_OPTIONS+=\
-DBUILD_LIBTELLDUS-CORE=1 \
-DBUILD_TDTOOL=1 \
-DGENERATE_MAN=0 \
-DICONV_LIBRARY=-liconv
-TARGET_CXXFLAGS += -fpermissive
-
-define Package/telldus-core/conffiles
-/etc/tellstick.conf
-endef
+TARGET_CXXFLAGS += $(if $(ICONV_FULL),-D_FREEBSD)
define Package/telldus-core/install
$(INSTALL_DIR) $(1)/usr/bin