aboutsummaryrefslogtreecommitdiff
path: root/utils/telldus-core/Makefile
diff options
context:
space:
mode:
authorPeter Liedholm <PeterFromSwe884@gmail.com>2019-01-19 17:04:14 +0100
committerPeter Liedholm <PeterFromSwe884@gmail.com>2019-03-01 21:19:45 +0100
commit03f255c9f01e9347825eb1e21f03d388af5337b2 (patch)
tree3758677fcb045c30ca04fd52927802d55f7306ca /utils/telldus-core/Makefile
parent2a4d79be0d07c76c98965bcde0cf435764dbbc72 (diff)
telldus-core: Add new package.
Signed-off-by: Peter Liedholm <PeterFromSwe884@gmail.com>
Diffstat (limited to 'utils/telldus-core/Makefile')
-rw-r--r--utils/telldus-core/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/utils/telldus-core/Makefile b/utils/telldus-core/Makefile
new file mode 100644
index 000000000..0dbe28f0f
--- /dev/null
+++ b/utils/telldus-core/Makefile
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2010 Telldus Technologies AB
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=telldus-core
+PKG_VERSION:=2.1.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=LGPL-2.1
+PKG_BUILD_DEPENDS:=argp-standalone
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.telldus.com/TellStick/Software/telldus-core/
+PKG_HASH:=a20f6c74814afc23312d2c93ebbb37fdea9deaaee05ae7b6a6275e11e4662014
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/telldus-core
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Telldus TellStick USB interface
+ URL:=http://www.telldus.com
+ MAINTAINER:=Peter Liedholm <PeterFromSwe884@gmail.com>
+ DEPENDS:=+confuse +libftdi +libstdcpp $(ICONV_DEPENDS)
+endef
+
+define Package/telldus-core/description
+ Telldus driver for USB-based 433 MHz RF transceiver for home automation.
+ MUST be built with full language support, (don't know how to DEPEND that)
+endef
+
+CMAKE_OPTIONS+=\
+ -DBUILD_LIBTELLDUS-CORE=1 \
+ -DBUILD_TDTOOL=1 \
+ -DGENERATE_MAN=0 \
+ -DICONV_LIBRARY=-liconv
+
+define Package/telldus-core/conffiles
+/etc/tellstick.conf
+endef
+
+define Package/telldus-core/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tdtool $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/telldusd $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tdadmin $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libtelldus* $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/tellstick.conf $(1)/etc
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/telldusd $(1)/etc/init.d
+endef
+
+$(eval $(call BuildPackage,telldus-core))