aboutsummaryrefslogtreecommitdiff
path: root/utils/sysstat
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-18 20:42:00 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-18 20:42:37 +0200
commit431ad5f6828bda7bc10ae03dc5354da6eea0e6f6 (patch)
tree3f77bd4abd887a955ee66e8db5a6426d937e99e8 /utils/sysstat
parent4116e327afee80aaea33a16358f5f7c0da687bec (diff)
sysstat: fix musl compatibility
Add missing `limits.h` and `sys/types.h` includes to the appropriate source files. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'utils/sysstat')
-rw-r--r--utils/sysstat/Makefile2
-rw-r--r--utils/sysstat/patches/100-musl-compat.patch30
2 files changed, 31 insertions, 1 deletions
diff --git a/utils/sysstat/Makefile b/utils/sysstat/Makefile
index 0c463815d..3e9457b25 100644
--- a/utils/sysstat/Makefile
+++ b/utils/sysstat/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sysstat
PKG_VERSION:=11.0.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
diff --git a/utils/sysstat/patches/100-musl-compat.patch b/utils/sysstat/patches/100-musl-compat.patch
new file mode 100644
index 000000000..06c781327
--- /dev/null
+++ b/utils/sysstat/patches/100-musl-compat.patch
@@ -0,0 +1,30 @@
+--- a/sa_common.c
++++ b/sa_common.c
+@@ -28,6 +28,7 @@
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <libgen.h>
++#include <limits.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+--- a/common.c
++++ b/common.c
+@@ -30,6 +30,7 @@
+ #include <dirent.h>
+ #include <ctype.h>
+ #include <libgen.h>
++#include <limits.h>
+
+ #include "version.h"
+ #include "common.h"
+--- a/ioconf.c
++++ b/ioconf.c
+@@ -27,6 +27,7 @@
+ #include <errno.h>
+ #include <dirent.h>
+ #include <sys/stat.h>
++#include <sys/types.h>
+
+ #include "ioconf.h"
+ #include "common.h"