aboutsummaryrefslogtreecommitdiff
path: root/utils/syncthing
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-23 16:21:10 -1000
committerPaul Spooren <mail@aparcar.org>2020-03-23 16:37:36 -1000
commitb85e387cc2dec49ccaf0063f2b109e5c6151de39 (patch)
tree3d0c4d72eb7059eb7ed96023222cae4d9d05a320 /utils/syncthing
parent43d0e0778950dc2d8801b03491da040de2f75601 (diff)
syncthing: fixup version detection
Since upstream commit dc92994 the LDFLAGS used for settings the version (and build host and user) changed resulting in "unknown" versions in syncthing. Correct version detection is important for syncthing to assure compatibility with other running instances. The "unknown" version fails to communicate and sync with correctly compiled instances. This patch updates the syncthing Makefile to inject the correct variables and thereby fixes the version detection in syncthing. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'utils/syncthing')
-rw-r--r--utils/syncthing/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/utils/syncthing/Makefile b/utils/syncthing/Makefile
index f55f511d9..cc431b4ee 100644
--- a/utils/syncthing/Makefile
+++ b/utils/syncthing/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=syncthing
PKG_VERSION:=1.3.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=syncthing-source-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/syncthing/syncthing/releases/download/v$(PKG_VERSION)
@@ -35,10 +35,11 @@ define Package/syncthing
endef
GO_PKG_LDFLAGS_X:=\
- main.Version=v$(PKG_VERSION) \
- main.BuildUser=openwrt \
- main.BuildHost=openwrt \
- main.BuildStamp=$(SOURCE_DATE_EPOCH)
+ github.com/syncthing/syncthing/lib/build.Version=v$(PKG_VERSION) \
+ github.com/syncthing/syncthing/lib/build.Stamp=$(SOURCE_DATE_EPOCH) \
+ github.com/syncthing/syncthing/lib/build.User=openwrt \
+ github.com/syncthing/syncthing/lib/build.Host=openwrt \
+ github.com/syncthing/syncthing/lib/build.Program=syncthing
define Build/Compile
$(call GoPackage/Build/Compile,-tags noupgrade)