aboutsummaryrefslogtreecommitdiff
path: root/utils/stress
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-11-23 14:02:27 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2015-11-23 16:08:26 +0200
commit4ee146b69280795d20985de3079bfc0c560ce00c (patch)
tree91e434ebf4e7104ba536d9b217c9f25f9ec155e9 /utils/stress
parent35ab69b62fa0d618e7ff47a2f7df4e79f1e96c8c (diff)
stress: bring it back (from old packages)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'utils/stress')
-rw-r--r--utils/stress/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/utils/stress/Makefile b/utils/stress/Makefile
new file mode 100644
index 000000000..c1fbce3fd
--- /dev/null
+++ b/utils/stress/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=stress
+PKG_VERSION:=1.0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://people.seas.harvard.edu/~apw/stress/
+PKG_MD5SUM:=a607afa695a511765b40993a64c6e2f4
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/stress
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=stress is a simple stress utility
+ URL:=http://people.seas.harvard.edu/~apw/stress/
+ MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+endef
+
+define Package/stress/description
+stress is a simple tool that imposes certain types of compute \ stress on
+UNIX-like operating systems.
+endef
+
+CONFIGURE_ARGS += \
+ --prefix="/usr"
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS)"
+
+define Package/stress/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stress $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,stress))