aboutsummaryrefslogtreecommitdiff
path: root/utils/stm32flash/Makefile
diff options
context:
space:
mode:
authorChristian Pointner <equinox@spreadspace.org>2014-06-14 07:54:52 +0200
committerChristian Pointner <equinox@spreadspace.org>2014-06-14 07:54:52 +0200
commit7653bbfb219e841b2fb538bb7c7d2b47b6dec817 (patch)
tree3485848364775ad5b3063678f6f509495cd0b8ee /utils/stm32flash/Makefile
parent13d6e6f3b40fa7b20108f9f36c7760f1780886b8 (diff)
import stm32flash
Diffstat (limited to 'utils/stm32flash/Makefile')
-rw-r--r--utils/stm32flash/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/utils/stm32flash/Makefile b/utils/stm32flash/Makefile
new file mode 100644
index 000000000..19d2d47bf
--- /dev/null
+++ b/utils/stm32flash/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=stm32flash
+PKG_REV:=61
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://stm32flash.googlecode.com/svn/trunk
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/stm32flash
+ SECTION:=utils
+ CATEGORY:=Utilities
+ URL:=http://code.google.com/p/stm32flash/
+ TITLE:=Firmware flash tool for STM32's serial bootloader
+endef
+
+define Package/stm32flash/description
+ This tool can be used to burn firmware images to STM32 ARM processors
+ using the built-in serial bootloader.
+endef
+
+define Package/stm32flash/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/stm32flash $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,stm32flash))