aboutsummaryrefslogtreecommitdiff
path: root/utils/sshpass/Makefile
diff options
context:
space:
mode:
authorMichal Hrušecký <michal.hrusecky@nic.cz>2017-10-21 08:53:47 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-02-15 13:45:30 +0100
commit18ccf174d6e13117e33cf75dbb3a892ce3cbd443 (patch)
treedaaeee507b453898f3f28abd17acf496e7796b01 /utils/sshpass/Makefile
parent43fd0476529fa1eae4f824d55018267f03f68ce3 (diff)
sshpass: add new package
Signed-off-by: Michal Hrušecký <michal.hrusecky@nic.cz> Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'utils/sshpass/Makefile')
1 files changed, 37 insertions, 0 deletions
diff --git a/utils/sshpass/Makefile b/utils/sshpass/Makefile
new file mode 100644
index 000000000..74f433b6b
--- /dev/null
+++ b/utils/sshpass/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sshpass
+PKG_VERSION:=1.06
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/sshpass
+PKG_HASH:=c6324fcee608b99a58f9870157dfa754837f8c48be3df0f5e2f3accf145dee60
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sshpass
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Non-interactive ssh password auth
+ URL:=https://sourceforge.net/projects/sshpass/
+endef
+
+define Package/sshpass/description
+ Sshpass is a tool for non-interactively performing password authentication
+ with SSH's so-called "interactive keyboard password authentication". Most user
+ should use SSH's more secure public-key authentication instead.
+endef
+
+define Package/sshpass/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sshpass $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,sshpass))