aboutsummaryrefslogtreecommitdiff
path: root/utils/sispmctl/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-06-17 16:02:53 -0700
committerRosen Penev <rosenp@gmail.com>2018-07-07 10:27:24 -0700
commit2a141f0052eeb19a8bcc7a5e20a39e7f0570560f (patch)
tree9fac96c1566c39f8f40c0d43a196b58cea470e0c /utils/sispmctl/Makefile
parent0a264360d678d7ed5a690749ce5b7fd21fd74f6b (diff)
sispmctl: Update to 4.0
Switched from git to tarball. There seems to be no activity since release 4.0. Removed unneeded patches. Added a library package since it seems to be required now. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/sispmctl/Makefile')
-rw-r--r--utils/sispmctl/Makefile33
1 files changed, 22 insertions, 11 deletions
diff --git a/utils/sispmctl/Makefile b/utils/sispmctl/Makefile
index 77a73fddf..76500c9f5 100644
--- a/utils/sispmctl/Makefile
+++ b/utils/sispmctl/Makefile
@@ -8,29 +8,34 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sispmctl
-PKG_VERSION:=3.1+20120206
+PKG_VERSION:=4.0
PKG_RELEASE:=1
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=5ff4a05a5bcb6a64a9d6f77fed47014512f66b11
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MIRROR_HASH:=d09782160dbcc1ba3bd6a38941f38e130049d8383843f6f292409909678aed82
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://git.code.sf.net/p/sispmctl/git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_HASH:=442d9bb9774da7214c222144035ac68ad5d25171040ce2731cfdf49b3365cfd5
PKG_MAINTAINER:=Richard Kunze <richard.kunze@web.de>
PKG_LICENSE:=GPL-2.0+
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
+define Package/libsispmctl
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Silver Shield PM Control for Linux library
+ URL:=http://sispmctl.sourceforge.net
+ DEPENDS:=+libusb-compat
+endef
+
define Package/sispmctl
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Silver Shield PM Control for Linux
- URL:=http://sispmctl.sourceforge.net/
- DEPENDS:=+libusb-compat
+ URL:=http://sispmctl.sourceforge.net
+ DEPENDS:=+libsispmctl
endef
define Package/sispmctl/description
@@ -49,9 +54,15 @@ CONFIGURE_ARGS += \
--enable-webless \
--disable-dependency-tracking
+define Package/libsispmctl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libsispmctl* $(1)/usr/lib/
+endef
+
define Package/sispmctl/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sispmctl $(1)/usr/bin/
endef
+$(eval $(call BuildPackage,libsispmctl))
$(eval $(call BuildPackage,sispmctl))