aboutsummaryrefslogtreecommitdiff
path: root/utils/shared-mime-info/Makefile
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2022-02-13 19:03:53 -0600
committerRosen Penev <rosenp@gmail.com>2022-02-14 17:18:32 -0800
commit1cb6f062004fcd1b278ed946f6f535ded52d1836 (patch)
tree601d3542e64fecc3f08f0b634f072b1c0e1a626d /utils/shared-mime-info/Makefile
parent69c53fcb6ce58a23c51cb9c1a403f5843a565f44 (diff)
shared-mime-info: new package
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'utils/shared-mime-info/Makefile')
-rw-r--r--utils/shared-mime-info/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/utils/shared-mime-info/Makefile b/utils/shared-mime-info/Makefile
new file mode 100644
index 000000000..1b607ba22
--- /dev/null
+++ b/utils/shared-mime-info/Makefile
@@ -0,0 +1,53 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shared-mime-info
+PKG_VERSION:=2.1
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=shared-mime-info-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://gitlab.freedesktop.org/xdg/$(PKG_NAME)/-/archive/$(PKG_VERSION)
+PKG_HASH:=37df6475da31a8b5fc63a54ba0770a3eefa0a708b778cb6366dccee96393cb60
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/meson.mk
+
+define Package/shared-mime-info
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+glib2 +libxml2
+ TITLE:=MIME-type information
+ URL:=https://freedesktop.org/wiki/Software/shared-mime-info/
+endef
+
+define Package/shared-mime-info/description
+ The shared-mime-info package contains a database of MIME types and their file extensions.
+endef
+
+define Package/shared-mime-info/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/bin/* \
+ $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/share/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/share/* \
+ $(1)/usr/share/
+endef
+
+define Package/shared-mime-info/postinst
+#!/bin/sh
+
+update-mime-database /usr/share/mime/
+endef
+
+$(eval $(call BuildPackage,shared-mime-info))