aboutsummaryrefslogtreecommitdiff
path: root/utils/runc
diff options
context:
space:
mode:
authorGerard Ryan <G.M0N3Y.2503@gmail.com>2020-07-27 09:40:37 +0000
committerGerard Ryan <G.M0N3Y.2503@gmail.com>2020-07-29 20:39:31 +1000
commitf13797524ad995547d7ca2cba7e7a3c9a9eaee20 (patch)
tree1d47bc3585e7dedbb6bfa8d4ba191785f7ffa42d /utils/runc
parentd13f7612939e01acebbf633a9bfefbb109a4deba (diff)
runc: Removed DevInstall target and Refactor
Signed-off-by: Gerard Ryan <G.M0N3Y.2503@gmail.com>
Diffstat (limited to 'utils/runc')
-rw-r--r--utils/runc/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index 605b852b7..8bece6b0a 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=runc
PKG_VERSION:=1.0.0-rc10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -15,6 +15,7 @@ PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
PKG_BUILD_DEPENDS:=golang/host
PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
PKG_USE_MIPS16:=0
GO_PKG:=github.com/opencontainers/runc
@@ -50,8 +51,7 @@ endef
GO_PKG_INSTALL_ALL:=1
MAKE_PATH:=$(GO_PKG_WORK_DIR_NAME)/build/src/$(GO_PKG)
MAKE_VARS += $(GO_PKG_VARS)
-MAKE_FLAGS += \
- COMMIT=$(PKG_SOURCE_VERSION)
+MAKE_FLAGS += COMMIT=$(PKG_SOURCE_VERSION)
ifeq ($(ARCH),mips)
MAKE_FLAGS += EXTRA_FLAGS='-buildmode=default'
@@ -63,16 +63,8 @@ else
MAKE_FLAGS += BUILDTAGS=''
endif
-define Build/Compile
- $(call Build/Compile/Default)
-endef
-
-# Avoid installing binaries
-define Build/InstallDev
- $(call Build/Compile/Default,clean)
- rm -f $(STAMP_BUILT)
- $(call GoPackage/Build/InstallDev,$(1))
-endef
+# Reset golang-package.mk overrides so we can use the Makefile
+Build/Compile=$(call Build/Compile/Default)
define Package/runc/install
$(INSTALL_DIR) $(1)/usr/sbin/