aboutsummaryrefslogtreecommitdiff
path: root/utils/runc
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-11-19 13:35:13 +0000
committerDaniel Golle <dangowrt@users.noreply.github.com>2020-11-21 23:55:47 +0000
commitbf3697b5c171ed6d6c5905ad8be67f2b1d9f6caa (patch)
tree9c8b677821fa99fc02762bb74ada39aeec2932eb /utils/runc
parentc976b3aaa076dad09fca9e6eacf9ee27c4a3bc1e (diff)
runc: enable seccomp support by default
It's nice to have seccomp support which is enabled in OpenWrt on supported platforms on targets which are not marked as SMALL_FLASH. (and it's kinda obvious that you wouldn't want to install runc on a SMALL_FLASH target to begin with) So let's enable seccomp by default. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils/runc')
-rw-r--r--utils/runc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index 8bece6b0a..4d1fe8ca1 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=runc
PKG_VERSION:=1.0.0-rc10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -26,9 +26,9 @@ include ../../lang/golang/golang-package.mk
define Package/runc/config
config RUNC_SECCOMP
depends on PACKAGE_runc
+ depends on KERNEL_SECCOMP
bool "Enable support for seccomp in runc"
- default DOCKER_SECCOMP
- select KERNEL_SECCOMP
+ default y
select PACKAGE_libseccomp
help
Build runc with support for seccomp filters.