aboutsummaryrefslogtreecommitdiff
path: root/utils/runc/Makefile
diff options
context:
space:
mode:
authorTexot Qi <tete1030@gmail.com>2020-02-27 01:05:45 +0800
committerTexot Qi <tete1030@gmail.com>2020-02-27 10:23:33 +0800
commitbffa542f7a648a803c8820ecee1036d82194df45 (patch)
treef9908d7fd994b96dbe02edcc43e76f9b4af05d34 /utils/runc/Makefile
parent0798a11fadfe3ee966a422d6748793d30e3bfbb1 (diff)
runc: fix incomplete cleanup in Build/InstallDev
Currently it only cleans up binaries when executing Build/InstallDev without deleting .built stamp file. This leads to wrong information about existence of built runc binaries and causes error when executing package/runc/install twice. Signed-off-by: Texot Qi <tete1030@gmail.com>
Diffstat (limited to 'utils/runc/Makefile')
-rw-r--r--utils/runc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index e4c2756d7..e8cb4140a 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=runc
PKG_VERSION:=1.0.0-rc8+91-3e425f80
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -72,6 +72,7 @@ endef
# Avoid installing binaries
define Build/InstallDev
$(call Build/Compile/Default,clean)
+ rm -f $(STAMP_BUILT)
$(call GoPackage/Build/InstallDev,$(1))
endef