aboutsummaryrefslogtreecommitdiff
path: root/utils/runc/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-02-04 21:48:08 +0800
committerJeffery To <jeffery.to@gmail.com>2020-02-05 14:19:34 +0800
commit89d3f0ab54a0a1d22a0ce5903fc5067fdc64bbc0 (patch)
treee66246521dbfa50ec78966c4204cff3944c8cc6f /utils/runc/Makefile
parent3bc32984267997098a785e2c0ce5cc4942fb45e8 (diff)
golang: Reorganize GoPackage/Environment and Makefile variables
* Move more environment variables into GoPackage/Environment * Split GoPackage/Environment into target and build sections * Do not set GOROOT_FINAL for Go packages (setting it should only affect the Go compiler and not Go packages) * Set CGO_LDFLAGS to $(TARGET_LDFLAGS) * Move GO_TARGET_* variables from golang-values.mk, and GO_VERSION_* variables from golang-version.mk, into golang/Makefile This also updates runc, containerd, and docker-ce to reflect the changes in GoPackage/Environment. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils/runc/Makefile')
-rw-r--r--utils/runc/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index 43fb53355..e4c2756d7 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=runc
PKG_VERSION:=1.0.0-rc8+91-3e425f80
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -51,14 +51,7 @@ endef
GO_PKG_INSTALL_ALL:=1
MAKE_PATH:=$(GO_PKG_WORK_DIR_NAME)/build/src/$(GO_PKG)
-MAKE_VARS += \
- GOPATH=$(GO_PKG_BUILD_DIR) \
- GOCACHE=$(GO_PKG_CACHE_DIR) \
- GOTMPDIR=$(GO_PKG_TMP_DIR) \
- GOROOT_FINAL=$(GO_TARGET_ROOT) \
- CC=$(TARGET_CC) \
- CXX=$(TARGET_CXX) \
- $(call GoPackage/Environment)
+MAKE_VARS += $(call GoPackage/Environment)
MAKE_FLAGS += \
COMMIT=$(PKG_SOURCE_VERSION)