aboutsummaryrefslogtreecommitdiff
path: root/utils/runc/Makefile
diff options
context:
space:
mode:
authorGerard Ryan <G.M0N3Y.2503@gmail.com>2020-11-08 12:05:23 +1000
committerDaniel Golle <daniel@makrotopia.org>2020-11-22 02:05:28 +0000
commit3a06ce55959016653767a1d2c276594ad1eeb743 (patch)
tree1f04fd7e11ffbfbafd696aeb537031e98d32eb61 /utils/runc/Makefile
parent0caf99038087550365d6bf7555b2f66bb1281856 (diff)
runc: Updated to v1.0.0-rc92 for dockerd
SELinux and Seccomp are now enabled via the kernel options themselves Signed-off-by: Gerard Ryan <G.M0N3Y.2503@gmail.com>
Diffstat (limited to 'utils/runc/Makefile')
-rw-r--r--utils/runc/Makefile33
1 files changed, 12 insertions, 21 deletions
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index 4d1fe8ca1..cb012fc83 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -1,15 +1,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=runc
-PKG_VERSION:=1.0.0-rc10
-PKG_RELEASE:=3
+PKG_VERSION:=1.0.0-rc92
+PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/opencontainers/runc/tar.gz/v${PKG_VERSION}?
-PKG_HASH:=6b44985023347fb9c5a2cc6f761df8c41cc2c84a7a68a6e6acf834dff6653a9a
-PKG_SOURCE_VERSION:=dc9208a3303feef5b3839f4323d9beb36df0a9dd
+PKG_HASH:=28378df983a3c586ed3ec8c76a774a9b10f36a0c323590a284b801cce95cc61f
+PKG_SOURCE_VERSION:=ff819c7e9184c13b7c2607fe6c30ae19403a7aff
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
@@ -23,24 +23,12 @@ GO_PKG:=github.com/opencontainers/runc
include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
-define Package/runc/config
-config RUNC_SECCOMP
- depends on PACKAGE_runc
- depends on KERNEL_SECCOMP
- bool "Enable support for seccomp in runc"
- default y
- select PACKAGE_libseccomp
- help
- Build runc with support for seccomp filters.
- Select libseccomp which also pulls-in the needed kernel features.
-endef
-
define Package/runc
SECTION:=utils
CATEGORY:=Utilities
TITLE:=runc container runtime
URL:=https://www.opencontainers.org/
- DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +RUNC_SECCOMP:libseccomp
+ DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +KERNEL_SECCOMP_FILTER:libseccomp
MENU:=1
endef
@@ -57,11 +45,14 @@ ifeq ($(ARCH),mips)
MAKE_FLAGS += EXTRA_FLAGS='-buildmode=default'
endif
-ifeq ($(CONFIG_RUNC_SECCOMP),y)
-MAKE_FLAGS += BUILDTAGS='seccomp'
-else
-MAKE_FLAGS += BUILDTAGS=''
+BUILDTAGS:=
+ifeq ($(CONFIG_KERNEL_SECCOMP_FILTER),y)
+BUILDTAGS += seccomp
+endif
+ifeq ($(CONFIG_SELINUX),y)
+BUILDTAGS += selinux
endif
+MAKE_FLAGS += BUILDTAGS='$(BUILDTAGS)'
# Reset golang-package.mk overrides so we can use the Makefile
Build/Compile=$(call Build/Compile/Default)