aboutsummaryrefslogtreecommitdiff
path: root/utils/rtty
diff options
context:
space:
mode:
authorJianhui Zhao <jianhuizhao329@gmail.com>2018-02-06 17:20:46 +0800
committerJianhui Zhao <jianhuizhao329@gmail.com>2018-02-07 17:10:08 +0800
commit62e4f714f5d1f45f73207f0b3783f4bffcf58fb9 (patch)
tree65e64612f86928c278822daf264d9b9024f90ccb /utils/rtty
parent9cd7e4dfe4f7c66351cd809c144f638f5aaaa8ee (diff)
rtty: Update to 3.1.1
Signed-off-by: Jianhui Zhao <jianhuizhao329@gmail.com>
Diffstat (limited to 'utils/rtty')
-rwxr-xr-xutils/rtty/Makefile4
-rwxr-xr-xutils/rtty/files/rtty.config1
-rw-r--r--utils/rtty/files/rtty.init5
3 files changed, 6 insertions, 4 deletions
diff --git a/utils/rtty/Makefile b/utils/rtty/Makefile
index a04f584b0..f8c6c6a74 100755
--- a/utils/rtty/Makefile
+++ b/utils/rtty/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtty
-PKG_VERSION:=2.2.0
+PKG_VERSION:=3.1.2
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_SOURCE_URL=https://github.com/zhaojh329/rtty.git
-PKG_MIRROR_HASH:=23a203351fdd47acfd16d3c3b3e3d51dd65a5d9e8ca89d4b1521d40c40616102
+PKG_MIRROR_HASH:=aef16014cca633550adf3385149c883a618b6875479d8874887bea41d783bd63
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
diff --git a/utils/rtty/files/rtty.config b/utils/rtty/files/rtty.config
index 8e7123a9b..dd8694a0f 100755
--- a/utils/rtty/files/rtty.config
+++ b/utils/rtty/files/rtty.config
@@ -10,3 +10,4 @@
# option host 'your-server-host' # Server host
# option port '5912' # Server Port
# option ssl 1 # Whether to use ssl
+# option ping 5 # heartbeat interval(second)
diff --git a/utils/rtty/files/rtty.init b/utils/rtty/files/rtty.init
index ab3ba131d..1c7c6e44d 100644
--- a/utils/rtty/files/rtty.init
+++ b/utils/rtty/files/rtty.init
@@ -17,7 +17,8 @@ start_rtty() {
'description:maxlength(126)' \
'host:host' \
'port:port' \
- 'ssl:bool:0'
+ 'ssl:bool:0' \
+ 'ping:uinteger:5'
[ $? -eq 1 ] && {
echo "validation failed" >&2
@@ -42,7 +43,7 @@ start_rtty() {
}
procd_open_instance
- procd_set_param command $BIN -h $host -p $port -a
+ procd_set_param command $BIN -h $host -p $port -a -P $ping
[ -n "$ifname" ] && procd_append_param command -i "$ifname"
[ -n "$id" ] && procd_append_param command -I "$id"
[ -n "$description" ] && procd_append_param command -d "$description"