aboutsummaryrefslogtreecommitdiff
path: root/utils/rtty
diff options
context:
space:
mode:
authorJianhui Zhao <zhaojh329@gmail.com>2022-05-22 22:01:18 +0800
committerRosen Penev <rosenp@gmail.com>2022-05-22 13:38:27 -0700
commit0ea357c164d4d265d750459de2ad6a63149fe89e (patch)
treea4abb8a33772f74a4eb3094b8f8228ac9f8a4aee /utils/rtty
parentd926da5182a4547e5248dad3e3e59abcd41d126f (diff)
rtty: update to 8.0.1
Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
Diffstat (limited to 'utils/rtty')
-rw-r--r--utils/rtty/Makefile6
-rw-r--r--utils/rtty/patches/100-wolfssl_5_support.patch21
2 files changed, 3 insertions, 24 deletions
diff --git a/utils/rtty/Makefile b/utils/rtty/Makefile
index cd6f34f33..0b995eb42 100644
--- a/utils/rtty/Makefile
+++ b/utils/rtty/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rtty
-PKG_VERSION:=8.0.0
-PKG_RELEASE:=2
+PKG_VERSION:=8.0.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/rtty/releases/download/v$(PKG_VERSION)
-PKG_HASH:=b9c555005b76c1ad0f5af891964375bbdf50ee22b9a9f53ddd48d2cdb4e53b49
+PKG_HASH:=b1a21819c2256b3364b8c64dfcc56583b9647409ab8b39ff54e00e242e44028e
PKG_MAINTAINER:=Jianhui Zhao <zhaojh329@gmail.com>
PKG_LICENSE:=MIT
diff --git a/utils/rtty/patches/100-wolfssl_5_support.patch b/utils/rtty/patches/100-wolfssl_5_support.patch
deleted file mode 100644
index 096a32ef0..000000000
--- a/utils/rtty/patches/100-wolfssl_5_support.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-commit 91b66a6b402b790f3c8cebb0420ef549744ee197
-Author: Sergey V. Lobanov <sergey@lobanov.in>
-Date: Mon Jan 3 19:25:45 2022 +0300
-
- add compatibility for wolfssl >= 5.0
-
- NTRU support has been removed in wolfssl 5.0 so it is required to
- mask NTRU specific code if wolfssl >= 5.0
-
---- a/src/ssl/openssl.c
-+++ b/src/ssl/openssl.c
-@@ -336,7 +336,9 @@ static bool handle_wolfssl_asn_error(voi
- case ASN_SIG_HASH_E:
- case ASN_SIG_KEY_E:
- case ASN_DH_KEY_E:
-+#if LIBWOLFSSL_VERSION_HEX < 0x05000000
- case ASN_NTRU_KEY_E:
-+#endif
- case ASN_CRIT_EXT_E:
- case ASN_ALT_NAME_E:
- case ASN_NO_PEM_HEADER: