aboutsummaryrefslogtreecommitdiff
path: root/utils/rpcd-mod-lxc/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-12-07 16:54:11 +0100
committerKarel Kočí <karel.koci@nic.cz>2020-12-09 10:16:37 +0100
commit54b6116d7d3f6df94df621dcabdc0c158fd4b5f2 (patch)
treef37daeb5dfb1d9951af292777f7464b50b9a7188 /utils/rpcd-mod-lxc/Makefile
parent40086b9e561fb8d35d9fe1f2a616cb5a18efc4cb (diff)
rpcd-mod-lxc: add postinst to reload rpcd on update/installation
This is dependency of luci-app-lxc and when users install that package it is no way clear that they have to reload rpcd to get it working correctly. Without it container listing does not work. In general this reload should be in this package simply because other rpcd-mod-* packages reload rpcd as well. Signed-off-by: Karel Kočí <karel.koci@nic.cz>
Diffstat (limited to 'utils/rpcd-mod-lxc/Makefile')
-rw-r--r--utils/rpcd-mod-lxc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/utils/rpcd-mod-lxc/Makefile b/utils/rpcd-mod-lxc/Makefile
index fc333612c..289b2d124 100644
--- a/utils/rpcd-mod-lxc/Makefile
+++ b/utils/rpcd-mod-lxc/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd-mod-lxc
-PKG_RELEASE=20171206
+PKG_RELEASE=20201208
PKG_LICENSE:=ISC
@@ -34,4 +34,9 @@ define Package/rpcd-mod-lxc/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/lxc.so $(1)/usr/lib/rpcd/
endef
+define Package/rpcd-mod-lxc/postinst
+#!/bin/sh
+[ -n "$$IPKG_INSTROOT" ] || /etc/init.d/rpcd reload
+endef
+
$(eval $(call BuildPackage,rpcd-mod-lxc))