aboutsummaryrefslogtreecommitdiff
path: root/utils/rpcd-mod-lxc/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-10-10 15:44:49 +0200
committerLuka Perkov <luka.perkov@sartura.hr>2014-10-21 07:58:47 -0400
commit153e482090bcdf22facb9a868991057d2a61d775 (patch)
tree3e56dbd1622248a83d4546731ecf3298ed205e0a /utils/rpcd-mod-lxc/Makefile
parent952912aea1f395d05ebcc71e0f9b2587a6a1b2c3 (diff)
rpcd-mod-lxc: add package for rpcd lxc module
Signed-off-by: Luka Perkov <luka@openwrt.org>
Diffstat (limited to 'utils/rpcd-mod-lxc/Makefile')
-rw-r--r--utils/rpcd-mod-lxc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/utils/rpcd-mod-lxc/Makefile b/utils/rpcd-mod-lxc/Makefile
new file mode 100644
index 000000000..ccabc39d7
--- /dev/null
+++ b/utils/rpcd-mod-lxc/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rpcd-mod-lxc
+PKG_RELEASE=20141012
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/rpcd-mod-lxc
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=LXC rpcd module
+ DEPENDS:=+rpcd +liblxc
+ MAINTAINER:=Luka Perkov <luka@openwrt.org>
+endef
+
+define Build/Prepare
+ $(CP) ./files/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/rpcd-mod-lxc/install
+ $(INSTALL_DIR) $(1)/usr/lib/rpcd
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/lxc.so $(1)/usr/lib/rpcd/
+endef
+
+$(eval $(call BuildPackage,rpcd-mod-lxc))