aboutsummaryrefslogtreecommitdiff
path: root/utils/rng-tools/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-09-22 14:25:34 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2016-09-22 14:25:34 +0300
commite77de68fbef6b8715dd1189a13bbfeee0e50e426 (patch)
treed22672b4f553bfd34d5e12959348a0d8b71c9316 /utils/rng-tools/Makefile
parent54e4a971f7b4efbbc8cf9a2fca2dfc34a2e8544c (diff)
rng-tools: Add description, remove unused parameter
* Add description to both Makefile and init script that mentions the default of /dev/urandom as the entropy source. * Remove the deprecated interval parameter from init script. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils/rng-tools/Makefile')
-rw-r--r--utils/rng-tools/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/utils/rng-tools/Makefile b/utils/rng-tools/Makefile
index 8ec18c2ce..b97cbf2ae 100644
--- a/utils/rng-tools/Makefile
+++ b/utils/rng-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rng-tools
PKG_VERSION:=5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/gkernel/rng-tools/$(PKG_VERSION)/
@@ -30,6 +30,12 @@ define Package/rng-tools
URL:=http://sourceforge.net/projects/gkernel/
endef
+define Package/rng-tools/description
+Daemon for adding entropy to kernel entropy pool. By default it uses
+/dev/urandom as the source but the init script can be modified
+to use a hardware source like /dev/hwrng if present
+endef
+
ifdef CONFIG_USE_UCLIBC
CONFIGURE_VARS += \
LIBS="-largp"