aboutsummaryrefslogtreecommitdiff
path: root/utils/rng-tools/Makefile
diff options
context:
space:
mode:
authorNathaniel Filardo <nwfilardo@gmail.com>2020-07-11 15:26:23 +0100
committerNathaniel Filardo <nwfilardo@gmail.com>2020-08-22 14:17:03 +0100
commit79f706b3ab823fe42518705611386d956a3164e2 (patch)
treef85c002048f5bc78ffadf49f904f764572f06506 /utils/rng-tools/Makefile
parent46f727e57d5626f5f7d15abebfa8952bfa788c88 (diff)
rng-tools: bump to 6.10, require libopenssl
Upstream now requires libopenssl unconditionally Signed-off-by: Nathaniel Filardo <nwfilardo@gmail.com>
Diffstat (limited to 'utils/rng-tools/Makefile')
-rw-r--r--utils/rng-tools/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/utils/rng-tools/Makefile b/utils/rng-tools/Makefile
index 0618c8409..653fbcf7a 100644
--- a/utils/rng-tools/Makefile
+++ b/utils/rng-tools/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rng-tools
-PKG_VERSION:=6.7
+PKG_VERSION:=6.10
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/nhorman/rng-tools
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=05cb68b8600025f362ea0875f5966b60f8195f91ed89b431996a48cd88b1e5b0
+PKG_MIRROR_HASH:=853341a3be05164616ba11a8cf983847477e02d6d43a259fc2352dbec262d649
PKG_MAINTAINER:=Nathaniel Wesley Filardo <nwfilardo@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
@@ -32,7 +32,7 @@ define Package/rng-tools
CATEGORY:=Utilities
TITLE:=Daemon for adding entropy to kernel entropy pool
URL:=https://github.com/nhorman/rng-tools
- DEPENDS:=+libsysfs
+ DEPENDS:=+libsysfs +libopenssl
endef
define Package/rng-tools/description
@@ -42,9 +42,9 @@ define Package/rng-tools/description
endef
CONFIGURE_ARGS += \
- --without-libgcrypt \
--without-nistbeacon \
- --without-pkcs11
+ --without-pkcs11 \
+ --without-rtlsdr
ifndef CONFIG_USE_GLIBC
CONFIGURE_VARS += LIBS="-largp"