aboutsummaryrefslogtreecommitdiff
path: root/utils/rng-tools/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2015-06-17 11:33:38 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2015-06-17 11:33:38 +0300
commit23334b9816114da0f34da260ae4699b0f4159f46 (patch)
tree60a144036900fa3cc0d5899a3237f630e6857661 /utils/rng-tools/Makefile
parentf48315ba03e7ba9804e38381dc56445098f6b700 (diff)
rng-tools: musl compatibility
Make rng-tools to compile with musl by adding similar argp dependencies as with uclibc. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils/rng-tools/Makefile')
-rw-r--r--utils/rng-tools/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/utils/rng-tools/Makefile b/utils/rng-tools/Makefile
index d45a197c4..8ec18c2ce 100644
--- a/utils/rng-tools/Makefile
+++ b/utils/rng-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011-2014 OpenWrt.org
+# Copyright (C) 2011-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rng-tools
PKG_VERSION:=5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/gkernel/rng-tools/$(PKG_VERSION)/
@@ -19,7 +19,7 @@ PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
PKG_FIXUP:=autoreconf
-PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
include $(INCLUDE_DIR)/package.mk
@@ -35,6 +35,11 @@ CONFIGURE_VARS += \
LIBS="-largp"
endif
+ifdef CONFIG_USE_MUSL
+CONFIGURE_VARS += \
+ LIBS="-largp"
+endif
+
CONFIGURE_ARGS += \
--without-libgcrypt