aboutsummaryrefslogtreecommitdiff
path: root/utils/ripgrep
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-22 16:29:06 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-22 10:50:24 -0800
commit64c7a4d7a196d38683c6d9008d49bf7fdc7378bb (patch)
tree7ea86a5b3bb4b5843ae9c9c2e56bea873f4d8515 /utils/ripgrep
parent65955c3b1e38dca76bec4864430e1abadc20dae6 (diff)
ripgrep: update to 14.1.0
- Link pcre2 dynamically - it was linked statically and libpcre2 dependency was useless - it magically fixes build error when global LTO is enabled - it reduces resulting binary size - Use 'release-lto' cargo profile to further reduce binary size 'rg' binary sizes comparision (arm_cortex-a9+neon): - 4293KB: unmodified - 4018KB: dynamic libpcre2 - 3521KB: dynamic libpcre2 + release-lto Signed-off-by: krant <aleksey.vasilenko@gmail.com>
Diffstat (limited to 'utils/ripgrep')
-rw-r--r--utils/ripgrep/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/utils/ripgrep/Makefile b/utils/ripgrep/Makefile
index 0d3c9210e..2c5e1a0c6 100644
--- a/utils/ripgrep/Makefile
+++ b/utils/ripgrep/Makefile
@@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ripgrep
-PKG_VERSION:=13.0.0
-PKG_RELEASE:=2
+PKG_VERSION:=14.1.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/BurntSushi/ripgrep/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=0fb17aaf285b3eee8ddab17b833af1e190d73de317ff9648751ab0660d763ed2
+PKG_HASH:=33c6169596a6bbfdc81415910008f26e0809422fda2d849562637996553b2ab6
PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
PKG_LICENSE:=MIT Unlicense
@@ -25,6 +25,11 @@ RUST_PKG_FEATURES:=pcre2
include $(INCLUDE_DIR)/package.mk
include ../../lang/rust/rust-package.mk
+## Force pcre2-sys crate to link dynamically with libpcre2
+export PCRE2_SYS_STATIC=0
+## Most optimized profile
+CARGO_PKG_PROFILE:=release-lto
+
define Package/ripgrep
SECTION:=utils
CATEGORY:=Utilities