aboutsummaryrefslogtreecommitdiff
path: root/utils/ripgrep
diff options
context:
space:
mode:
authorLuca Barbato <luca.barbato@gmail.com>2023-03-09 08:58:16 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-03-10 14:24:16 +0000
commit44d1d22a16e25b1e06fae86e157718069b7069f6 (patch)
treec8ffc0bae5ec9debda98ca059a30ed489ffd89fc /utils/ripgrep
parent674bad05591f2c969297576062b9dcba00a30ea7 (diff)
rust-lang: Apply suggestions from code review
Co-authored-by: Tianling Shen <cnsztl@gmail.com> Signed-off-by: Luca Barbato <luca.barbato@gmail.com>
Diffstat (limited to 'utils/ripgrep')
-rw-r--r--utils/ripgrep/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/utils/ripgrep/Makefile b/utils/ripgrep/Makefile
index 4a6c766b2..fe449bc2d 100644
--- a/utils/ripgrep/Makefile
+++ b/utils/ripgrep/Makefile
@@ -8,10 +8,13 @@ PKG_NAME:=ripgrep
PKG_VERSION:=13.0.0
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/BurntSushi/ripgrep/archive/refs/tags/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/BurntSushi/ripgrep/tar.gz/$(PKG_VERSION)?
PKG_HASH:=0fb17aaf285b3eee8ddab17b833af1e190d73de317ff9648751ab0660d763ed2
+
PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+PKG_LICENSE:=MIT Unlicense
+PKG_LICENSE_FILES:=LICENSE-MIT UNLICENSE
PKG_BUILD_DEPENDS:=rust/host
@@ -22,21 +25,22 @@ define Build/Compile
$(call Build/Compile/Cargo,, --features 'pcre2')
endef
-define Package/$(PKG_NAME)
- SECTION:=utils
- CATEGORY:=Utilities
- DEPENDS:=$(RUST_ARCH_DEPENDS) +libpcre2
- TITLE:=ripgrep (rg) regex grep
- URL:=https://github.com/BurntSushi/ripgrep
+define Package/ripgrep
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=ripgrep (rg) regex grep
+ DEPENDS:=$(RUST_ARCH_DEPENDS) +libpcre2
+ URL:=https://github.com/BurntSushi/ripgrep
endef
-define Package/$(PKG_NAME)/description
-ripgrep (rg) recursively searches directories for a regex pattern while respecting your gitignore
+define Package/ripgrep/description
+ ripgrep (rg) recursively searches directories for a regex pattern
+ while respecting your gitignore
endef
-define Package/$(PKG_NAME)/install
+define Package/ripgrep/install
$(INSTALL_DIR) $(1)/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/target/$(RUSTC_TARGET_ARCH)/stripped/rg $(1)/bin/rg
endef
-$(eval $(call BuildPackage,$(PKG_NAME)))
+$(eval $(call BuildPackage,ripgrep))