aboutsummaryrefslogtreecommitdiff
path: root/utils/readsb
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-29 16:52:36 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-30 14:53:21 -0700
commit94eacb36eaf432117cd3fbd0bb24fe1e2709caf0 (patch)
treef58b39fc8b4bfb0dce68e5a39da2e28a1ecb0400 /utils/readsb
parentc11726f14a996e9085ef5d6cb785e8c5f2c4e174 (diff)
readsb: fix compilation with GCC10
Upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/readsb')
-rw-r--r--utils/readsb/Makefile2
-rw-r--r--utils/readsb/patches/010-gcc10.patch61
2 files changed, 62 insertions, 1 deletions
diff --git a/utils/readsb/Makefile b/utils/readsb/Makefile
index 535580ccb..dc46e98cf 100644
--- a/utils/readsb/Makefile
+++ b/utils/readsb/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=readsb
PKG_VERSION:=3.8.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/Mictronics/readsb/tar.gz/v$(PKG_VERSION)?
diff --git a/utils/readsb/patches/010-gcc10.patch b/utils/readsb/patches/010-gcc10.patch
new file mode 100644
index 000000000..2ef972294
--- /dev/null
+++ b/utils/readsb/patches/010-gcc10.patch
@@ -0,0 +1,61 @@
+From 5119c21ae56f1c7fd0b10250d1beca9634bf74af Mon Sep 17 00:00:00 2001
+From: Mictronics <github@mictronics.de>
+Date: Sun, 14 Jun 2020 18:06:22 +0200
+Subject: [PATCH] Clean up linkage of struct Modes.
+
+---
+ readsb.c | 2 ++
+ readsb.h | 6 ++++--
+ viewadsb.c | 2 ++
+ 3 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/readsb.c b/readsb.c
+index e784d891..d6dab324 100644
+--- a/readsb.c
++++ b/readsb.c
+@@ -57,6 +57,8 @@
+
+ #include <stdarg.h>
+
++struct _Modes Modes;
++
+ //
+ // ============================= Program options help ==========================
+ //
+diff --git a/readsb.h b/readsb.h
+index 3a1b22d5..1b80c338 100644
+--- a/readsb.h
++++ b/readsb.h
+@@ -312,7 +312,7 @@ struct mag_buf
+
+ // Program global state
+
+-struct
++struct _Modes
+ { // Internal state
+ pthread_cond_t data_cond; // Conditional variable associated
+ pthread_t reader_thread;
+@@ -412,7 +412,9 @@ struct
+ struct stats stats_15min;
+ struct timespec reader_cpu_accumulator; // CPU time used by the reader thread, copied out and reset by the main thread under the mutex
+ struct mag_buf mag_buffers[MODES_MAG_BUFFERS]; // Converted magnitude buffers from RTL or file input
+-} Modes;
++};
++
++extern struct _Modes Modes;
+
+ // The struct we use to store information about a decoded message.
+
+diff --git a/viewadsb.c b/viewadsb.c
+index ad7b1bd0..915305b6 100644
+--- a/viewadsb.c
++++ b/viewadsb.c
+@@ -54,6 +54,8 @@
+ #include "readsb.h"
+ #include "help.h"
+
++struct _Modes Modes;
++
+ #define _stringize(x) x
+ #define verstring(x) _stringize(x)
+