aboutsummaryrefslogtreecommitdiff
path: root/utils/quota
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2021-01-30 19:31:02 -0600
committerHannu Nyman <hannu.nyman@iki.fi>2021-01-31 13:35:42 +0200
commitba4839f3c79f680ae8bcb0a97e9a07610ced9560 (patch)
tree7dfe9d43a5562347f376405e2b332318cf761976 /utils/quota
parent9133e79ccb864bb2d92a386fc104258dc6c28de0 (diff)
quota: update to 4.06
This includes a backport of quota commit 02b222a3, which removes the use of reallocarray. The musl C library does not provide reallocarray. Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'utils/quota')
-rw-r--r--utils/quota/Makefile6
-rw-r--r--utils/quota/patches/020-remove-reallocarray.patch13
2 files changed, 16 insertions, 3 deletions
diff --git a/utils/quota/Makefile b/utils/quota/Makefile
index 49af89eb1..74b59429c 100644
--- a/utils/quota/Makefile
+++ b/utils/quota/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=quota
-PKG_VERSION:=4.05
-PKG_RELEASE:=3
+PKG_VERSION:=4.06
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/linuxquota
-PKG_HASH:=ef3b5b5d1014ed1344b46c1826145e20cbef8db967b522403c9a060761cf7ab9
+PKG_HASH:=2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/utils/quota/patches/020-remove-reallocarray.patch b/utils/quota/patches/020-remove-reallocarray.patch
new file mode 100644
index 000000000..942e38eeb
--- /dev/null
+++ b/utils/quota/patches/020-remove-reallocarray.patch
@@ -0,0 +1,13 @@
+diff --git a/quota.c b/quota.c
+index a6ed61f..a60de12 100644
+--- a/quota.c
++++ b/quota.c
+@@ -385,7 +385,7 @@ int main(int argc, char **argv)
+ break;
+ case 259:
+ fscount++;
+- fsnames = reallocarray(fsnames, fscount, sizeof(char *));
++ fsnames = realloc(fsnames, fscount * sizeof(char *));
+ if (!fsnames)
+ die(1, _("Not enough memory for filesystem names"));
+ fsnames[fscount - 1] = optarg;