aboutsummaryrefslogtreecommitdiff
path: root/utils/quota/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-13 20:48:33 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-14 16:18:14 -0700
commite1935bb4b61828f13781d1c0b01907cc4f5aac45 (patch)
treef61acb02226dfea39fce19156d6339966db500b0 /utils/quota/Makefile
parent1812713faf404b8f195a454b251c3c541c0e6c96 (diff)
quote: disable a bunch of options
libwrap is fairly useless. It's also legacy and should not be used/ dbus is a big dependency. It's fairly useless in the OpenWrt context. I don't know how useful netlink is. Disabling BSD behavior results in a slightly smaller size. Disable LDAP. No size difference but I have a feeling it pulls in another dependency... Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/quota/Makefile')
-rw-r--r--utils/quota/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/utils/quota/Makefile b/utils/quota/Makefile
index 6f140d5ef..9633a79b8 100644
--- a/utils/quota/Makefile
+++ b/utils/quota/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=quota
PKG_VERSION:=4.05
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/linuxquota
@@ -25,7 +25,6 @@ include $(INCLUDE_DIR)/package.mk
define Package/quota
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libnl-genl +libtirpc +libwrap
TITLE:= quota
URL:=https://sourceforge.net/projects/linuxquota/
endef
@@ -35,7 +34,13 @@ define Package/quota/description
endef
CONFIGURE_ARGS += \
- --disable-ext2direct
+ --disable-bsd-behaviour \
+ --disable-ext2direct \
+ --disable-ldapmail \
+ --disable-libwrap \
+ --disable-netlink \
+ --disable-rpath \
+ --disable-rpc
define Package/quota/install
$(INSTALL_DIR) $(1)/usr/bin