aboutsummaryrefslogtreecommitdiff
path: root/utils/qemu
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-08-18 11:23:59 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2016-08-18 11:28:21 +0800
commitac0ea8b970566364172ae3bd824e1d3c46331b84 (patch)
tree301f93f9e7cea5b91638c7dc63a9c66600b94176 /utils/qemu
parent2dc0eebc0b41dfbf2743f28b5ac3f1ad49605d64 (diff)
qemu: build only qemu-ga
This has two effects - Saves time and computing resources. Non-relevant tools like qemu-img, qemu-io will not be built - Fixes packaging failure on octeon target caused by failure of building internal pixman library Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'utils/qemu')
-rw-r--r--utils/qemu/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index 974524d99..0990ec0ca 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -42,13 +42,28 @@ CONFIGURE_ARGS:=$(filter-out \
--disable-nls \
, $(CONFIGURE_ARGS))
-# Building qemu-ga alone does not require zlib
-CONFIGURE_ARGS+= \
+# Building qemu-ga alone does not require zlib, pixman
+#
+# --disable-tools to disable building pixman which will fail at the moment on
+# octeon mips64 target.
+CONFIGURE_ARGS += \
--cross-prefix=$(TARGET_CROSS) \
--host-cc="$(HOSTCC)" \
--target-list='' \
--disable-zlib-test \
- --enable-guest-agent
+ --enable-guest-agent \
+ --disable-tools \
+ --without-pixman
+
+ifneq ($(CONFIG_PACKAGE_qemu-ga),)
+CONFIGURE_ARGS += --enable-guest-agent
+endif
+
+MAKE_VARS += V=s
+
+define Build/Compile
+ $(if $(CONFIG_PACKAGE_qemu-ga),$(call Build/Compile/Default,qemu-ga))
+endef
define Package/qemu-ga/install
$(INSTALL_DIR) $(1)/usr/bin