aboutsummaryrefslogtreecommitdiff
path: root/utils/qemu/Makefile
diff options
context:
space:
mode:
authorVladimir Ermakov <vooon341@gmail.com>2022-01-13 00:41:31 +0300
committerYousong Zhou <yszhou4tech@gmail.com>2022-01-18 12:53:27 +0800
commit421fb2fea46e3c3acea0b48938e67d95983d6330 (patch)
tree30903ca80df11962745bc10e4c20d847e16e9c64 /utils/qemu/Makefile
parenta2ba5e57cbc90a8d0d52f994ec700e9d8c04f11e (diff)
qemu: update to 6.2.0
Qemu version updated to 6.2.0, patch set refreshed for it. Options --disable-jemalloc --disable-tcmalloc was replaced by --enable-malloc=CHOICE, defaults to system. Libudev search was moved from configure to meson.build, and now it's not so easy to disable it. Even though --disable-mpath present. Delete patches 0008-falloc and 0009-fs - they're already in 6.2.0. Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
Diffstat (limited to 'utils/qemu/Makefile')
-rw-r--r--utils/qemu/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index d47e74edf..22b46c5ec 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
-PKG_VERSION:=6.1.0
+PKG_VERSION:=6.2.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=eebc089db3414bbeedf1e464beda0a7515aad30f73261abc246c9b27503a3c96
+PKG_HASH:=68e15d8e45ac56326e0b9a4afa8b49a3dfe8aba3488221d098c84698bca65b45
PKG_SOURCE_URL:=http://download.qemu.org/
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
@@ -53,7 +53,7 @@ define Package/qemu-ga
SUBMENU:=Virtualization
TITLE:=QEMU Guest Agent
URL:=http://www.qemu.org
- DEPENDS:= +glib2 +virtio-console-helper +libstdcpp $(QEMU_DEPS_IN_GUEST)
+ DEPENDS:= +glib2 +virtio-console-helper +libstdcpp +libudev $(QEMU_DEPS_IN_GUEST)
endef
define Package/qemu-ga/install
@@ -197,7 +197,7 @@ define qemu-target
+QEMU_UI_VNC_SASL:libsasl2 \
+QEMU_UI_SPICE:libspice-server \
+QEMU_DEV_USB:libusb-1.0 \
- $(if $(filter %-softmmu,$(1)),+libncurses +libfdt +libslirp +pixman +qemu-firmware-efi $(ICONV_DEPENDS))
+ $(if $(filter %-softmmu,$(1)),+libncurses +libfdt +libslirp +libudev +pixman +qemu-firmware-efi $(ICONV_DEPENDS))
endef
define Package/qemu-$(1)/description
@@ -390,12 +390,10 @@ CONFIGURE_ARGS += \
--disable-glusterfs \
--disable-gnutls \
--disable-guest-agent-msi \
- --disable-jemalloc \
--disable-libiscsi \
--disable-libnfs \
--disable-libpmem \
--disable-libssh \
- --disable-libudev \
--$(if $(CONFIG_QEMU_DEV_USB),enable,disable)-libusb \
--disable-libxml2 \
--disable-linux-aio \
@@ -421,7 +419,6 @@ CONFIGURE_ARGS += \
--disable-sparse \
--disable-strip \
--disable-tcg-interpreter \
- --disable-tcmalloc \
--disable-tpm \
--disable-usb-redir \
--disable-vde \
@@ -431,6 +428,10 @@ CONFIGURE_ARGS += \
--disable-xkbcommon \
--disable-xfsctl \
--disable-zstd \
+ --disable-selinux \
+ --disable-oss \
+ --disable-alsa \
+ --disable-pa \
CONFIGURE_ARGS += --target-list='$(foreach target,$(qemu-target-list),$(if $(CONFIG_PACKAGE_qemu-$(target)),$(target)))'
CONFIGURE_ARGS += $(if $(CONFIG_PACKAGE_qemu-ga),--enable-guest-agent)