aboutsummaryrefslogtreecommitdiff
path: root/utils/qemu/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-08-11 23:39:16 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-08-12 00:05:37 +0800
commit1e836cb41a08ddcab785aa2445d25494d846d25b (patch)
tree2eef58e2e912f2f83efaecfcd324d6aea6bc40e8 /utils/qemu/Makefile
parent100bd27e4d0cffd791b1c9c533e5f1d41f62168b (diff)
qemu: fix build failure caused by ld cannot find iconv
This was caused by upstream project commit db5adeaa ("build-sys: clean up flags included in the linker command line") Reported-by: W. Michael Petullo <mike@flyn.org> Link: https://github.com/openwrt/packages/issues/13081 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'utils/qemu/Makefile')
-rw-r--r--utils/qemu/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index ffb39cb15..57792c8b4 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
PKG_VERSION:=5.0.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=2f13a92a0fa5c8b69ff0796b59b86b080bbb92ebad5d301a7724dd06b5e78cb6
PKG_SOURCE_URL:=http://download.qemu.org/
@@ -288,9 +288,9 @@ CONFIGURE_ARGS += \
--host-cc="$(HOSTCC)" \
--disable-fortify-source \
--disable-stack-protector \
- --extra-cflags="$(EXTRA_CFLAGS)" \
- --extra-cxxflags="$(EXTRA_CXXFLAGS)" \
- --extra-ldflags="$(EXTRA_LDFLAGS)" \
+ --extra-cflags="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+ --extra-cxxflags="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)" \
+ --extra-ldflags="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
# VHost features
CONFIGURE_ARGS += \