aboutsummaryrefslogtreecommitdiff
path: root/utils/psmisc
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2021-04-18 13:59:30 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2021-04-18 14:31:11 +0200
commitd8969e0fd1db2b2cb544cea19179a05aec5a9c28 (patch)
treec6e91942d01a7c1e6b5c77379767f4078899d1fd /utils/psmisc
parentfc01307d7a6963b536e322529757f8a0925bcc45 (diff)
psmisc: move killall to /usr/libexec and add ALTERNATIVES
Currently, this package can not be installed while using standard path of busybox, because binary killall wants to be installed on the same location as busybox. Collision: • /usr/bin/killall: busybox (new-file), psmisc (existing-file) Many of these binaries, which provides alternatives were moved to folder /usr/libexec like wget, sed, findutils, less. So I moved killall to /usr/libexec and others leave in touch and added ALTERNATIVES for it, because preinstall script is no longer necessary. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'utils/psmisc')
-rw-r--r--utils/psmisc/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/utils/psmisc/Makefile b/utils/psmisc/Makefile
index df15609d5..126edf4d4 100644
--- a/utils/psmisc/Makefile
+++ b/utils/psmisc/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=psmisc
PKG_VERSION:=23.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/psmisc
@@ -23,6 +23,7 @@ define Package/psmisc
TITLE:=proc utilities
URL:=https://gitlab.com/psmisc/psmisc/
DEPENDS:=+libncurses
+ ALTERNATIVES:=300:/usr/bin/killall:/usr/libexec/killall
endef
define Package/psmisc/description
@@ -38,16 +39,11 @@ MAKE_FLAGS += \
CPPFLAGS="$(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)"
-define Package/psmisc/preinst
-#!/bin/sh
-if [ -e $${IPKG_INSTROOT}/usr/bin/killall ]; then
- rm $${IPKG_INSTROOT}/usr/bin/killall;
-fi
-endef
-
define Package/psmisc/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{fuser,killall,prtstat,pstree} $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{fuser,prtstat,pstree} $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/killall $(1)/usr/libexec
endef
$(eval $(call BuildPackage,psmisc))