aboutsummaryrefslogtreecommitdiff
path: root/utils/procps-ng/Makefile
diff options
context:
space:
mode:
authorIan Cooper <iancooper@hotmail.com>2020-04-29 11:07:36 +0100
committerIan Cooper <iancooper@hotmail.com>2020-04-29 11:08:17 +0100
commitafd648e680cdf53be19ad96ac8ee012d2804b42d (patch)
tree438182c9f165b9afdefa16ab442d431d6c734e62 /utils/procps-ng/Makefile
parent62ef2a88390dd7942ec48e6d735fb7e1861878c8 (diff)
procps-ng: remove unnecessary PKG_BUILD_DEPENDS
The package Makefile contains an unnecessary PKG_BUILD_DEPENDS line that builds gettext and libiconv even in cases where the build has gettext-full and libiconv-full selected. This behaviour can and does mask errors in other package Makefiles that are dependent on libiconv-full if it is compiled before these packages by causing libiconv-stub to be created and put in the staging tree and potentially linked against by these dependent packages when they omit to specify an appropriate PKG_BUILD_DEPENDS line. procps-ng does not require gettext or libiconv to be built in order to compile correctly. Signed-off-by: Ian Cooper <iancooper@hotmail.com>
Diffstat (limited to 'utils/procps-ng/Makefile')
-rw-r--r--utils/procps-ng/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/utils/procps-ng/Makefile b/utils/procps-ng/Makefile
index fb9a4e69d..31adc9b56 100644
--- a/utils/procps-ng/Makefile
+++ b/utils/procps-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=procps-ng
PKG_VERSION:=3.3.15
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/procps-ng
@@ -22,7 +22,6 @@ PKG_LICENSE_FILES:=COPYING COPYING.LIB
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
-PKG_BUILD_DEPENDS:=gettext libiconv
include $(INCLUDE_DIR)/package.mk