aboutsummaryrefslogtreecommitdiff
path: root/utils/procps-ng/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-20 13:25:59 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-21 09:52:32 +0800
commit9ac5ac81ab2241b7c13c01e8801e0e7d95ebb4eb (patch)
tree8e917b35332bcae8517d6291258d80f0d44d4b46 /utils/procps-ng/Makefile
parent274b111782c1d7650ae244a16e141e39d339af32 (diff)
treewide: avoid deref symlinks when installing .so
This change is inspired by commit openwrt/openwrt@38b22b1e ("nghttp2: deduplicate files in libnghttp2") The packages in this commit are identified with the following command grep -rin -E 'INSTALL_(DATA|BIN)' | grep -F '.so' | grep -F '*' Some of them do not have symlinks and are not affected, but the change is still applied for consideration of best practices just in case Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'utils/procps-ng/Makefile')
-rw-r--r--utils/procps-ng/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/procps-ng/Makefile b/utils/procps-ng/Makefile
index 3f3892825..e813f63fb 100644
--- a/utils/procps-ng/Makefile
+++ b/utils/procps-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=procps-ng
PKG_VERSION:=3.3.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/procps-ng
@@ -91,7 +91,7 @@ MAKE_FLAGS += \
define Package/procps-ng/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
endef
define BuildPlugin