aboutsummaryrefslogtreecommitdiff
path: root/utils/procps-ng/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-08-14 14:06:20 +0200
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-08-14 14:21:44 +0200
commit8b1104ae91112861f7981475115f0906a9b82e98 (patch)
tree22fb7613d478143a547925831cc22cf9e9671b30 /utils/procps-ng/Makefile
parent34215c958ee74c9bd151c895a57613cd49434110 (diff)
procps-ng: add new applet sysctl
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'utils/procps-ng/Makefile')
-rw-r--r--utils/procps-ng/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/utils/procps-ng/Makefile b/utils/procps-ng/Makefile
index 7ee7ede9c..d6192da4f 100644
--- a/utils/procps-ng/Makefile
+++ b/utils/procps-ng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=procps-ng
PKG_VERSION:=3.3.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/procps-ng
@@ -81,6 +81,7 @@ define GenPlugin
endef
$(foreach a,$(PROCPS_APPLETS),$(eval $(call GenPlugin,procps-ng-$(a),$(a),$(call procps-applets-dir,$(a)))))
+$(eval $(call GenPlugin,procps-ng-sysctl,sysctl,/usr/sbin))
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \
@@ -92,6 +93,11 @@ define Package/procps-ng/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
endef
+define Package/procps-ng-sysctl/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/sysctl $(1)/usr/sbin
+endef
+
define BuildPlugin
define Package/$(1)/install
$(INSTALL_DIR) $$(1)$(3)
@@ -102,4 +108,5 @@ define BuildPlugin
endef
$(foreach a,$(PROCPS_APPLETS),$(eval $(call BuildPlugin,procps-ng-$(a),$(a),$(call procps-applets-dir,$(a)))))
+$(eval $(call BuildPackage,procps-ng-sysctl))
$(eval $(call BuildPackage,procps-ng))