aboutsummaryrefslogtreecommitdiff
path: root/utils/procps-ng/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-23 21:08:08 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-24 10:16:46 +0200
commit3048ebedec5b989a621529eec159cf5aa17b58b6 (patch)
treee6d7f9a72b7e72a6c26491cec8b7547972415e7c /utils/procps-ng/Makefile
parent01f86b1f300f715458ae81daf4d2fc6797bdd647 (diff)
procps-ng: fix build on systems without gettext development utilities
The current procps-ng Makefile calls the shipped autogen.sh script which introduces incorrect implicit dependencies on host utilities, leading to the following error observed on a minimal build system: (cd .../procps-ng-3.3.11; echo "3.3.11" > ".../procps-ng-3.3.11/.tarball-version"; ./autogen.sh ); You must have autopoint installed to generate procps-ng build system. The autopoint command is part of the GNU gettext package. Makefile:96: recipe for target '.../procps-ng-3.3.11/.configured_yynyyyyy' failed make[3]: *** [.../procps-ng-3.3.11/.configured_yynyyyyy] Error 1 Apply the following changes in order to fix compilation: - Apply the generic autoreconf fixup to generate configure and Makefiles - Use Build/Prepare to populate .tarball-version and revert Build/Configure to its default implementation - Disable to build of docs and tests as those require additional utilities not guaranteed to be present Fixes #2890. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'utils/procps-ng/Makefile')
-rw-r--r--utils/procps-ng/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/utils/procps-ng/Makefile b/utils/procps-ng/Makefile
index 44badfe02..a50ea8113 100644
--- a/utils/procps-ng/Makefile
+++ b/utils/procps-ng/Makefile
@@ -21,6 +21,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -39,9 +40,9 @@ define Package/procps-ng/Default
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
endef
-define Build/Configure
- (cd $(PKG_BUILD_DIR); echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"; ./autogen.sh );
- $(call Build/Configure/Default)
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"
endef
define Package/procps-ng