aboutsummaryrefslogtreecommitdiff
path: root/utils/powertop/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-04 11:45:52 -0700
committerRosen Penev <rosenp@gmail.com>2019-06-04 11:51:26 -0700
commit02a4ac87c0358a91ac613a2a18c35094d6ccf4bd (patch)
tree4c2ad50e17d4ad214b53aa2f5eda4de6ec8dd693 /utils/powertop/Makefile
parent438326179ed547e58e7b13f453133d0de023784e (diff)
powertop: Do not use fstack-protector on ARC
Not compatible. Instead of setting PKG_SSP, I had to do this as the powertop Makefile defines it. Use $(FPIC) instead of -fPIC to fix potential issues. Removed musl patch. Not needed anymore. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/powertop/Makefile')
-rw-r--r--utils/powertop/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/utils/powertop/Makefile b/utils/powertop/Makefile
index 15a5881e4..4fa32c542 100644
--- a/utils/powertop/Makefile
+++ b/utils/powertop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=powertop
PKG_VERSION:=2.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://01.org/sites/default/files/downloads/
@@ -39,8 +39,14 @@ define Package/powertop/description
and power management.
endef
+TARGET_CFLAGS += $(FPIC)
+ifeq ($(CONFIG_USE_UCLIBC),y)
+TARGET_CFLAGS += -fno-stack-protector
+endif
TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
+CONFIGURE_ARGS += --without-pic
+
define Package/powertop/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/powertop \