aboutsummaryrefslogtreecommitdiff
path: root/utils/pciutils/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 13:48:45 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 17:18:51 -0700
commit3ffd13fbd2c16c1b297811702f6657ea10b62043 (patch)
treef121f96d9a5ab6bbbd6e161a8f816b61fd7271b3 /utils/pciutils/Makefile
parent43269ecf0178483968f2ed05af7cb1d63f345fda (diff)
pciutils: Fix build with external toolchains
Passing GNU_TARGET_NAME implies that we have a 4-group triplet (e.g: arm-openwrt-unknown-linux), and this works fine with pciutils' lib/configure operating system detection. If we have an external toolchain (e.g: mipsel-linux-gnu), the configure script is all confused and ends-up picking up i386-ports, which is not valid on the target architecture. Finally, we are not passing TARGET_CPPFLAGS as we should, so let's do that correctly. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'utils/pciutils/Makefile')
-rw-r--r--utils/pciutils/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/utils/pciutils/Makefile b/utils/pciutils/Makefile
index 3f61b4450..c0010cf77 100644
--- a/utils/pciutils/Makefile
+++ b/utils/pciutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
PKG_VERSION:=3.5.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -45,9 +45,9 @@ exit 0
endef
MAKE_FLAGS += \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
PREFIX="/usr" \
- HOST="$(GNU_TARGET_NAME)" \
+ HOST="Linux" \
HWDB="no" \
ZLIB="yes"