aboutsummaryrefslogtreecommitdiff
path: root/utils/openzwave
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2018-04-11 11:04:42 +0200
committerMarko Ratkaj <marko.ratkaj@sartura.hr>2018-04-11 14:30:49 +0200
commit1a4d9b7aba8da89bc7db27e0b024c80b541a1be0 (patch)
tree742178a6fc14358fecd15391fc6143bf603622af /utils/openzwave
parent30fa2156dafd85c1b197d2d3707473634d0cdba0 (diff)
openzwave: fix gcc7 compile and remove bad patch
Patch 903-no-examples.patch removes MinOZW binary. This is wrong since install section of openzwave is still using it. We can either remove the patch or remove install section for openzwave. It seems people are using this binary so we remove the patch. After removing the patch the following issue appears with gcc7: cc1plus: error: -Wformat-security ignored without -Wformat This is resolved by adding the following to Makefile TARGET_CPPFLAGS+=-Wno-format -Wno-format-security Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Diffstat (limited to 'utils/openzwave')
-rw-r--r--utils/openzwave/Makefile2
-rw-r--r--utils/openzwave/patches/903-no-examples.patch18
2 files changed, 2 insertions, 18 deletions
diff --git a/utils/openzwave/Makefile b/utils/openzwave/Makefile
index 1445c1a6d..da63dfb72 100644
--- a/utils/openzwave/Makefile
+++ b/utils/openzwave/Makefile
@@ -53,6 +53,8 @@ $(call Package/openzwave/default)
TITLE:=Open-ZWave Device Configs
endef
+TARGET_CPPFLAGS+=-Wno-format -Wno-format-security
+
MAKE_FLAGS += \
LD="$(TARGET_CROSS)g++" \
LIBDIR="$(PKG_BUILD_DIR)" \
diff --git a/utils/openzwave/patches/903-no-examples.patch b/utils/openzwave/patches/903-no-examples.patch
deleted file mode 100644
index 52ea13713..000000000
--- a/utils/openzwave/patches/903-no-examples.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -18,15 +18,12 @@
-
- all:
- CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS)
-- CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS)
-
- install:
- $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) $(MAKECMDGOALS)
-- $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS) $(MAKECMDGOALS)
-
- clean:
- $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) $(MAKECMDGOALS)
-- $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS) $(MAKECMDGOALS)
-
- cpp/src/vers.cpp:
- CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) cpp/src/vers.cpp