aboutsummaryrefslogtreecommitdiff
path: root/utils/openocd
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2023-01-20 13:14:40 +0000
committerKarl Palsson <karlp@etactica.com>2023-01-20 13:17:30 +0000
commitdd48483a60080ea5f3b83d5d4c71a9ac7b27043b (patch)
treeda7147fa19310b7684ef9c2f4fd6a1188d7bb28f /utils/openocd
parenta85935cf8fbb6347ff0460bb6abe088d8a4cc675 (diff)
openocd: select new libjaylink
Without the +select, openocd's internal autoselection between internal libjaylink and external libjaylink can result in linking against external, without the depends declaration, leading to missing depdendencies errors. Hard depend on the external libjaylink, as that's the future direction anyway. Reported-by: Paul Fertser <fercerpav@gmail.com> Signed-off-by: Karl Palsson <karlp@etactica.com>
Diffstat (limited to 'utils/openocd')
-rw-r--r--utils/openocd/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/openocd/Makefile b/utils/openocd/Makefile
index 56b28e72e..0792db288 100644
--- a/utils/openocd/Makefile
+++ b/utils/openocd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openocd
PKG_SOURCE_VERSION:=v0.12.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.code.sf.net/p/openocd/code
@@ -38,7 +38,8 @@ define Package/openocd
DEPENDS:=+libusb-1.0 \
+libftdi1 \
+hidapi \
- +libgpiod
+ +libgpiod \
+ +libjaylink
endef
define Package/openocd/description