aboutsummaryrefslogtreecommitdiff
path: root/utils/open2300/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-17 16:01:48 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-17 16:01:48 -0800
commitb2ba75c1c151d9e1aa9023ecee85ce40a9f54619 (patch)
tree99079e90695cfeffcb8a570f25728f8d93b49654 /utils/open2300/Makefile
parentd424c2c662481891ebac3687593faecc1d0141ef (diff)
open2300: link library to relative path instead of absolute
Fixes an InstallDev dead link. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/open2300/Makefile')
-rw-r--r--utils/open2300/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/utils/open2300/Makefile b/utils/open2300/Makefile
index 41da7bab0..fcbf5d8e0 100644
--- a/utils/open2300/Makefile
+++ b/utils/open2300/Makefile
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=open2300
PKG_SOURCE_DATE:=2014-03-04
PKG_SOURCE_VERSION:=1af8ae609da66f8e1b745533c19095c9758bfb0b
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/wezm/open2300
@@ -55,8 +55,8 @@ define Package/open2300/install
$(INSTALL_DATA) ./files/open2300.conf $(1)/etc/
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib2300.so.1.11 $(1)/usr/lib/
- ln -sf /usr/lib/lib2300.so.1.11 $(1)/usr/lib/lib2300.so
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/lib2300.so.1.11 $(1)/usr/lib/
+ $(LN) lib2300.so.1.11 $(1)/usr/lib/lib2300.so
endef
$(eval $(call BuildPackage,open2300))