aboutsummaryrefslogtreecommitdiff
path: root/utils/open-vm-tools
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-02-15 13:01:30 +0100
committerRosen Penev <rosenp@gmail.com>2022-09-22 01:29:04 -0700
commit710f04079e79303111b5c0190c5a667bdea0ae9f (patch)
treef2e3e704779b688f903de968ead6576283d98836 /utils/open-vm-tools
parent7e3a2f926bf8ec02a7cdb0114bcfdaf65ab19d73 (diff)
open-vm-tools: enable deploypkg plugin
Enable support functions for guest package deployment. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'utils/open-vm-tools')
-rw-r--r--utils/open-vm-tools/Makefile10
-rw-r--r--utils/open-vm-tools/files/telinit4
2 files changed, 12 insertions, 2 deletions
diff --git a/utils/open-vm-tools/Makefile b/utils/open-vm-tools/Makefile
index 406fe6e4b..72b1f4dfe 100644
--- a/utils/open-vm-tools/Makefile
+++ b/utils/open-vm-tools/Makefile
@@ -35,7 +35,11 @@ endef
define Package/open-vm-tools
$(call Package/open-vm-tools/Default)
- DEPENDS:=@TARGET_x86 +glib2 +libpthread +libtirpc
+ DEPENDS:=@TARGET_x86 \
+ +glib2 \
+ +libpthread \
+ +libtirpc \
+ +libmspack
TITLE:=open-vm-tools
URL:=https://github.com/vmware/open-vm-tools
MAINTAINER:=Yuhei OKAWA <tochiro.srchack@gmail.com>
@@ -68,7 +72,6 @@ CONFIGURE_ARGS+= \
--without-pam \
--disable-grabbitmqproxy \
--disable-vgauth \
- --disable-deploypkg \
--without-root-privileges \
--without-kernel-modules \
--without-dnet \
@@ -105,11 +108,13 @@ define Package/open-vm-tools/install
$(INSTALL_DIR) $(1)/sbin/
$(INSTALL_BIN) ./files/shutdown $(1)/sbin/
+ $(INSTALL_BIN) ./files/telinit $(1)/sbin/
$(INSTALL_DIR) $(1)/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libguestlib.so* $(1)/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libhgfs.so* $(1)/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libvmtools.so* $(1)/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libDeployPkg.so* $(1)/lib/
$(INSTALL_DIR) $(1)/usr/lib/open-vm-tools/plugins/common/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/common/libhgfsServer.so $(1)/usr/lib/open-vm-tools/plugins/common/
@@ -120,6 +125,7 @@ define Package/open-vm-tools/install
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libpowerOps.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libtimeSync.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libvmbackup.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libdeployPkgPlugin.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
$(INSTALL_DIR) $(1)/etc/hotplug.d/block/
$(INSTALL_BIN) ./files/vmware-scsi.hotplug $(1)/etc/hotplug.d/block/80-vmware-scsi
diff --git a/utils/open-vm-tools/files/telinit b/utils/open-vm-tools/files/telinit
new file mode 100644
index 000000000..3fa1c3c40
--- /dev/null
+++ b/utils/open-vm-tools/files/telinit
@@ -0,0 +1,4 @@
+#!/bin/sh
+#compatibility script for traditional customization
+
+/sbin/reboot