aboutsummaryrefslogtreecommitdiff
path: root/utils/open-vm-tools/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-30 02:46:48 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-01 16:26:08 -0800
commit436ac54916f9f500c8bbdd08897f1494e1d263a8 (patch)
treef055fd61807b4ccd51be0c18c06350405c57c8a8 /utils/open-vm-tools/patches
parent4fe39a4e2faad447ace173f34a1689bd3677296e (diff)
open-vm-tools: update to 11.2.0
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/open-vm-tools/patches')
-rw-r--r--utils/open-vm-tools/patches/0003-Use-configure-test-for-struct-timespec.patch2
-rw-r--r--utils/open-vm-tools/patches/0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch4
-rw-r--r--utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch6
-rw-r--r--utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch2
-rw-r--r--utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch6
-rw-r--r--utils/open-vm-tools/patches/0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch2
-rw-r--r--utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch2
-rw-r--r--utils/open-vm-tools/patches/010-musl-120.patch7
-rw-r--r--utils/open-vm-tools/patches/020-no-werror.patch2
9 files changed, 16 insertions, 17 deletions
diff --git a/utils/open-vm-tools/patches/0003-Use-configure-test-for-struct-timespec.patch b/utils/open-vm-tools/patches/0003-Use-configure-test-for-struct-timespec.patch
index 959fa6f4c..ef742dcf4 100644
--- a/utils/open-vm-tools/patches/0003-Use-configure-test-for-struct-timespec.patch
+++ b/utils/open-vm-tools/patches/0003-Use-configure-test-for-struct-timespec.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -1184,6 +1184,7 @@
+@@ -1195,6 +1195,7 @@ AC_TYPE_OFF_T
AC_TYPE_PID_T
AC_TYPE_SIZE_T
AC_CHECK_MEMBERS([struct stat.st_rdev])
diff --git a/utils/open-vm-tools/patches/0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch b/utils/open-vm-tools/patches/0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch
index 472d34334..dcd7c1e52 100644
--- a/utils/open-vm-tools/patches/0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch
+++ b/utils/open-vm-tools/patches/0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch
@@ -1,6 +1,6 @@
--- a/lib/hgfsServer/hgfsServerLinux.c
+++ b/lib/hgfsServer/hgfsServerLinux.c
-@@ -105,11 +105,13 @@
+@@ -105,11 +105,13 @@ typedef struct DirectoryEntry {
#endif
/*
@@ -28,5 +28,3 @@
#define ACCESSPERMS (S_IRWXU | S_IRWXG | S_IRWXO)
#endif
#ifdef __ANDROID__
-
-
diff --git a/utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch b/utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch
index 36a9018b4..bec5d34bc 100644
--- a/utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch
+++ b/utils/open-vm-tools/patches/0005-Use-configure-to-test-for-feature-instead-of-platfor.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -912,6 +912,7 @@
+@@ -923,6 +923,7 @@ AC_CHECK_FUNCS(
AC_CHECK_FUNCS([ecvt])
AC_CHECK_FUNCS([fcvt])
@@ -8,7 +8,7 @@
AC_CHECK_FUNC([mkdtemp], [have_mkdtemp=yes])
-@@ -1121,10 +1122,13 @@
+@@ -1132,10 +1133,13 @@ fi
###
AC_CHECK_HEADERS([crypt.h])
@@ -38,7 +38,7 @@
#ifdef __APPLE__
#include <sys/socket.h>
#include <TargetConditionals.h>
-@@ -1025,31 +1022,32 @@
+@@ -1025,31 +1022,32 @@ Id_EndSuperUser(uid_t uid) // IN:
static Bool
IdIsSetUGid(void)
{
diff --git a/utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch b/utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch
index 1bd1e56a7..b4d4a4622 100644
--- a/utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch
+++ b/utils/open-vm-tools/patches/0007-include-poll.h-instead-of-sys-poll.h.patch
@@ -1,6 +1,6 @@
--- a/lib/asyncsocket/asyncsocket.c
+++ b/lib/asyncsocket/asyncsocket.c
-@@ -69,8 +69,8 @@
+@@ -70,8 +70,8 @@
#else
#include <stddef.h>
#include <ctype.h>
diff --git a/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch b/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
index 861b0e93d..f527b0ea6 100644
--- a/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
+++ b/utils/open-vm-tools/patches/0008-Rename-poll.h-to-vm_poll.h.patch
@@ -1,6 +1,6 @@
--- a/lib/asyncsocket/asyncsocket.c
+++ b/lib/asyncsocket/asyncsocket.c
-@@ -86,7 +86,7 @@
+@@ -87,7 +87,7 @@
#include "random.h"
#include "asyncsocket.h"
#include "asyncSocketBase.h"
@@ -11,7 +11,7 @@
#include "hostinfo.h"
--- a/lib/hgfsServer/hgfsServer.c
+++ b/lib/hgfsServer/hgfsServer.c
-@@ -49,7 +49,7 @@
+@@ -51,7 +51,7 @@
#include "hgfsDirNotify.h"
#include "hgfsThreadpool.h"
#include "userlock.h"
@@ -22,7 +22,7 @@
#include "unicodeOperations.h"
--- a/lib/include/asyncsocket.h
+++ b/lib/include/asyncsocket.h
-@@ -169,7 +169,7 @@ typedef struct AsyncSocket AsyncSocket;
+@@ -171,7 +171,7 @@ typedef struct AsyncSocket AsyncSocket;
* Or the client can specify its favorite poll class and locking behavior.
* Use of IVmdbPoll is only supported for regular sockets and for Attach.
*/
diff --git a/utils/open-vm-tools/patches/0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch b/utils/open-vm-tools/patches/0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch
index 996708ad4..93ef93f19 100644
--- a/utils/open-vm-tools/patches/0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch
+++ b/utils/open-vm-tools/patches/0009-use-posix-strerror_r-unless-on-gnu-libc-system.patch
@@ -1,6 +1,6 @@
--- a/lib/err/errPosix.c
+++ b/lib/err/errPosix.c
-@@ -61,13 +61,7 @@ ErrErrno2String(Err_Number errorNumber, // IN
+@@ -61,13 +61,7 @@ ErrErrno2String(Err_Number errorNumber,
char *buf, // OUT: return buffer
size_t bufSize) // IN: size of buffer
{
diff --git a/utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch b/utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch
index d2407ad7d..ec48aa342 100644
--- a/utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch
+++ b/utils/open-vm-tools/patches/0014-resolve-musl-does-not-implement-res_ninit.patch
@@ -10,7 +10,7 @@
#ifdef __linux__
# include <net/if.h>
---- a/lib/nicInfo/resolv_compat.h
+--- /dev/null
+++ b/lib/nicInfo/resolv_compat.h
@@ -0,0 +1,29 @@
+#if !defined(__GLIBC__)
diff --git a/utils/open-vm-tools/patches/010-musl-120.patch b/utils/open-vm-tools/patches/010-musl-120.patch
index f6ca48543..b0537c0e8 100644
--- a/utils/open-vm-tools/patches/010-musl-120.patch
+++ b/utils/open-vm-tools/patches/010-musl-120.patch
@@ -9,7 +9,7 @@
uint32 sec;
uint32 nsec;
-@@ -134,7 +134,7 @@ HgfsConvertFromNtTimeNsec(struct timespec *unixTime, // OUT: Time in UNIX format
+@@ -134,7 +134,7 @@ HgfsConvertFromNtTimeNsec(struct timespe
return -1;
}
@@ -20,7 +20,7 @@
unixTime->tv_nsec = nsec * 100;
--- a/lib/hgfsServer/hgfsServerLinux.c
+++ b/lib/hgfsServer/hgfsServerLinux.c
-@@ -2569,7 +2569,11 @@ HgfsStatToFileAttr(struct stat *stats, // IN: stat information
+@@ -2573,8 +2573,12 @@ HgfsStatToFileAttr(struct stat *stats,
# define FMTTIMET "l"
# endif
#else
@@ -28,7 +28,8 @@
+# define FMTTIMET __PRI64
+#else
# define FMTTIMET "l"
-+#endif
#endif
++#endif
LOG(4, "access: %"FMTTIMET"d/%"FMT64"u \nwrite: %"FMTTIMET"d/%"FMT64"u \n"
"attr: %"FMTTIMET"d/%"FMT64"u\n",
+ stats->st_atime, attr->accessTime, stats->st_mtime, attr->writeTime,
diff --git a/utils/open-vm-tools/patches/020-no-werror.patch b/utils/open-vm-tools/patches/020-no-werror.patch
index 1f0cfe70d..be3fbbde0 100644
--- a/utils/open-vm-tools/patches/020-no-werror.patch
+++ b/utils/open-vm-tools/patches/020-no-werror.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -1199,7 +1199,6 @@ AC_C_VOLATILE
+@@ -1210,7 +1210,6 @@ AC_C_VOLATILE
### General flags / actions
CFLAGS="$CFLAGS -Wall"