aboutsummaryrefslogtreecommitdiff
path: root/utils/oath-toolkit
diff options
context:
space:
mode:
authorThlv Alivs <zgmzzzz18@gmail.com>2023-05-17 23:17:12 +0800
committerTianling Shen <cnsztl@gmail.com>2023-05-18 15:18:35 +0800
commita0c44d24e98338afdf54275ad369e5da5f4a1ae4 (patch)
treed5adba21008f44ea79737305f5cb3754e0d70ab8 /utils/oath-toolkit
parent77d9de45d0752e510c9afb0969e10da6a317f9df (diff)
oath-toolkit: add InstallDev section
This package seems to be missing an InstallDev section. Had a compile failure for an application that needs to compile against liboath Signed-off-by: Thlv Alivs <zgmzzzz18@gmail.com>
Diffstat (limited to 'utils/oath-toolkit')
-rw-r--r--utils/oath-toolkit/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/utils/oath-toolkit/Makefile b/utils/oath-toolkit/Makefile
index ebee2ec71..3063d1fa6 100644
--- a/utils/oath-toolkit/Makefile
+++ b/utils/oath-toolkit/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oath-toolkit
PKG_VERSION:=2.6.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/oath-toolkit
@@ -44,6 +44,13 @@ define Package/oath-toolkit/description
HOTP algorithm (RFC4226) and the time-based TOTP algorithm (RFC6238).
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/liboath
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
define Package/oath-toolkit/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib