aboutsummaryrefslogtreecommitdiff
path: root/utils/oath-toolkit/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-10-11 12:13:13 -0700
committerRosen Penev <rosenp@gmail.com>2018-10-11 12:13:13 -0700
commitea3981e0a51ffcf8ad7ffe54fdb61070a218d338 (patch)
tree61fa09e08e18a229dea8c94e4add2c4876536641 /utils/oath-toolkit/Makefile
parent0ecf61d51db948b230f3be88ea651dbd9819206d (diff)
oath-toolkit: Add patch from Fedora to fix compilation
Probably a result of GCC7 that it fails now. Added PKG_CPE_ID for proper CVE tracking. Added PKG_BUILD_PARALLEL for faster compilation. Reorganized Makefile slightly for consistency with other packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/oath-toolkit/Makefile')
-rw-r--r--utils/oath-toolkit/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/utils/oath-toolkit/Makefile b/utils/oath-toolkit/Makefile
index 55b716875..ebee904d6 100644
--- a/utils/oath-toolkit/Makefile
+++ b/utils/oath-toolkit/Makefile
@@ -9,14 +9,19 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oath-toolkit
PKG_VERSION:=2.6.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
+
PKG_SOURCE:=oath-toolkit-$(PKG_VERSION).tar.gz
-PKG_HASH:=b03446fa4b549af5ebe4d35d7aba51163442d255660558cd861ebce536824aa0
PKG_SOURCE_URL:=@SAVANNAH/oath-toolkit
+PKG_HASH:=b03446fa4b549af5ebe4d35d7aba51163442d255660558cd861ebce536824aa0
+
+PKG_MAINTAINER:=Fam Zheng <fam@euphon.net>
PKG_LICENSE:=LGPL-2.0+ GPL-3.0+
PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:nongnu:oath_toolkit
+
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_MAINTAINER:=Fam Zheng <fam@euphon.net>
include $(INCLUDE_DIR)/package.mk