aboutsummaryrefslogtreecommitdiff
path: root/utils/ntfs-3g/Makefile
diff options
context:
space:
mode:
authorRosy Song <rosysong@rosinson.com>2019-04-18 10:23:11 +0800
committerRosy Song <rosysong@rosinson.com>2019-04-18 16:09:30 +0800
commitaa5ac89d85ddf024d5d0e80137972492110ac66b (patch)
tree7b8086d6cf83a52c2cf32118186e98bd899d1aac /utils/ntfs-3g/Makefile
parentf53253aeda640f926f7772c39a09a5e544a78280 (diff)
ntfs-3g: allow build without ntfs3g.probe utility
This can save ~1024 Bytes size for the ipk Signed-off-by: Rosy Song <rosysong@rosinson.com>
Diffstat (limited to 'utils/ntfs-3g/Makefile')
-rw-r--r--utils/ntfs-3g/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/utils/ntfs-3g/Makefile b/utils/ntfs-3g/Makefile
index a943d9851..627871367 100644
--- a/utils/ntfs-3g/Makefile
+++ b/utils/ntfs-3g/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ntfs-3g
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=2017.3.23
PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
@@ -66,6 +66,10 @@ config PACKAGE_NTFS-3G_USE_LIBFUSE
etc.) it makes sense to activate this option and save some kilobytes
of space.
+config PACKAGE_NTFS-3G_HAS_PROBE
+ bool "install the ntfs-3g.probe utility"
+ depends on PACKAGE_ntfs-3g
+ default y
endef
define Package/ntfs-3g-low
@@ -150,7 +154,8 @@ endef
define Package/ntfs-3g/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g{,.probe} $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g $(1)/usr/bin/
+ $(if $(CONFIG_PACKAGE_NTFS-3G_HAS_PROBE),$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g.probe $(1)/usr/bin/,)
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/sbin